Zwift crashing unexpectedly after Big Sur upgrade

I have been a Zwift user for over a year. I run it primarily on Mac OS, with an iMac or a Mac Powerbook. I recently upgraded to Mac OS 11.1 (Big Sur) and have been having unexpected crashes during races or meetups. These are sudden and unexpected without any error notifications or crash logs. Suddenly the Zwift screen just disappears and there is no record of my riding or any part of the meetup or race. It happens whether or not I am using bluetooth or ANT+ for my trainer (Tacx Neo2T). It hasn’t happened while riding in Zwift, but seems to only happen in an organized event like meetup or race. While I primarily use my iMac for Zwifting, I haven’t tried my MacBook Pro as the primary computer, so I can’t say if this is also happening on my other Mac. Has anyone else had a similar experience since upgrading to Mac OS 11.1?

Hi @Glen_Winkel_OSI welcome to Zwift forums.

When is the crash happening? Right after startup? Once you enter a world? Before you end the session?

If it’s happening at the beginning - you may want to check and enable write permissions to the Documents folder for the Zwift app. Upgrading the OS can reset app permissions to a more restrictive default security setting that gets in the way of Zwift running correctly.

Worst case you might try a more heavhanded approach

  1. Search for “Zwift” in Finder
  2. Delete every folder and file in that search
  3. Download and install the Zwift game app
  4. When prompted, allow the permissions for everything that’s asked.

Would you try both of those options and let us know which worked? We like to hear when problems are solved.

Hello, after upgrading to Big Sur I have the same/similar problems. Using a Macbook plus Wahoo KICKR, mid-way during a workout my avatar stopped moving. After rebooting, my avatar simply does not move at all anymore. Uninstalling/reinstalling: no change. Deleting everything related to Zwift, downloading and installing: no change. Double-checked all the hardware: runs fine. Allowing document permission: Zwift does not show up under Files and Folders, ONLY under ‘Full Disk Access’? Changing that also does not change anything.

Would appreciate a workaround, thanks!