Problem since updating to macOS Big Sur

Hello, since a few day I have problems with suddenly she downs during a zwift training :face_vomiting:. I can"t do any workout. I use mac os big sur. Do you habe a solution for that ?

Cheers
Wifredo

@Mad_Ark_Nbg
Whenever you update your Mac’s OS, the update reverts some of your app preferences to the default settings that tightens user privacy.

For Zwift, this means you have to manually re-allow Zwift permissions to write to the Documents folder. If you don’t, the game can’t run properly. How-to’s on this Support Hub page, which says it’s for macOS Catalina, but the same applies to macOS Big Sur

Would you try that and let us know how this worked? We like to hear an affirmative yes / no.

I am on Big Sur, and I don’t see Zwift listed… Or does there appear to be a way to add Zwift to that list…

I can’t post images at this time… But the list for Files and Folders is completely empty.

That being said, I am able to add Zwift to “Full Disk Access” and it now appears in Files and Folders. Same thing ?

Any ideas ?
Thanks
J

@Justin_Knoetzke
Starting with OS Catalina, Apple tightened app permissions. Something that might also help your situation is to delete anything Zwift-related on your hard drive, and start a fresh install.

  1. Using Mac Finder, search for “Zwift.”
  2. Delete all the folders and files that came up in search. This step removes all the old stuff, and any potential conflicts that cause the game not to launch corectly.
  3. Download and install the latest Zwift game app from zwift.com/download
  4. VERY IMPORTANT: during installation, you’ll be prompted to allow Zwift access permissions. Should be for the Documents folder specifically, but if others come up, say yes. I’m on Windows personally, so I can’t say for sure what Big Sur asks for.

Would you try that and let us know if that solved your issue?

I wiped everything and re-installed and Zwift never asks for permission to access the Documents folder during the install.

Are you able to start the game, log in, etc?

Oh ya… I can ride no problem. The issue is that during a ride, it will crash… not always, but I’d say 60% of the time.

1 Like

Hi Shuji,

the permissions was already set. For two rides it worked yesterday and today it worked without crash. I used the free ride modus without any training-/workoutplan. The next time I will do a workout.

Cheers
Wifredo

Hello! I Have problem with Zwift whenever I use MacPro. It never happens on windows. The problem is that the automatic resistance generated by Zwift is way behind the terrain I’m riding when it’s uphill the resistance is dropping and on downhill is rising it looks like the resistance is way behind the track.
As I said last year I was using computer with Win or MacOS now I have only Mac and this is really annoying when you riding uphill 2km/h because you can’t make power without resistance.
Hope you guys now the problem and help me to solve it.

So, a few days it worked even doing a workout. But today it crashed during a workout again :hot_face:. Then I was doing a free ride training and it crashed again :face_vomiting:
After a reboot , I made a freeride training of nearly one hour without a crash.

The problem with Big Sur is still here and I’m very disappointed with Zwift, especially because I’ve started the trainigplan gravel grinder.
Do anyone has a solution or an idea?

Thx a lot

Hello @Mad_Ark_Nbg

It’s difficult to fix… There’s no logs or crash reports that indicate why it’s crashing. So, you have to do it by process of elimination. I too have the same issue as you and I too find that it works best right after a reboot. I suspect that there may be other applications causing issues for Zwift. Instead of rebooting, try shutting down all the running applications. If that works, then try to isolate which one is causing conflict. This by no means is a guarantee. This is all we really have to figure out what is causing the problem. It might also be hardware. Have you tried using the Companion app as a proxy for your devices instead of using a BLE or ANT+ on your Mac ? This changed nothing for me, but it might help you. Try ANT+ only instead of BLE… Or vice versa… etc etc… The fact that it works after a reboot means there is something causing a conflict for Zwift.

In my case, I think the problem was a running iOS simulator I use for iOS development… But I need to test a few more times to make sure.

There is supposed to be a new version coming in December for Big Sur. Fingers crossed.

Good luck !

txs Justin,

today it worked with a session of the training plan after closing all tasks and doing a reboot.

So I’m am waiting for the december update…

Cheers für now

so, next try -> next shut down :face_vomiting:
After closing all tasks and rebooting, Zwift was the only task (except finder), that’s was running. And then Zwift shot downs suddenly…

I’m so disappointed and I don’t know what I can do. There’s no valide training possible for me with the buggy Software Zwift at the moment and so I canceled my membership … I will test RGT now.

Do anyone know, when a new Zwift version ist coming ? Or any ideas, what I can try?