App doesn't start after I denied permission to my document folder

When I started the app on my Mac (BigSur), it asked me to give permission to my Documents folder. It surprised me and denied it.

After that I could log in, but the application doesn’t start.

I deleted the app, I deleted the Zwift folder in the Document folder and I deleted the Zwift folder in the Application Support Folder. I gave the app permission to the Document folder, but still it doesn’t start.

Still I don’t get it how the app knows my login credentials even after reinstall. After the reinstall I see that I’m already logged in, but if I click on “Let’s Go”, nothing happens.

What do I have to do now?

Hi @Adam_Szendrei

Sorry to hear that Zwift isn’t launching on your Mac, and that’s a tough one.

This article from Apple Support has the appropriate instructions for how to allow read/write access to specific folders on BigSur. Zwift needs this access to both the Documents and Downloads folders on MacOS. Without that access, the app won’t function.

  1. Also, make sure you’ve made the appropriate exclusions for the Documents and Downloads folders in any file sync apps you may use (e.g. GoogleDrive, Dropbox, etc…), and in any firewall apps you’ve installed (e.g. your antivirus).
  2. If you have a VPN or proxy, turn it off as it can block your connection to our servers.

If none of that helps, please send us a support request, and include all of the log files from your Mac. Our tech support team is happy to work with you on this. You can reach us here.

How can I reinstall the app?

I would like to reinstall and give the required permissions.

Hi @Adam_Szendrei , follow all the Mac-specific instructions in this article to re-install Zwift. Thanks!

As I have already mentioned I deleted all of the folders that the article mentioned.

What else do I have to delete?

Hi @Adam_Szendrei

The aforementioned article explaining how to re-install Zwift has step-by-step instructions, so I’d suggest following them as they’re detailed.

Deleting the Downloads and Documents folders are steps 3 and 4 of the Fresh Install Procedure. Assuming that’s where you’re at right now, continue on to step 5 and proceed from there.

Hope that helps!

The appropriate path forward should be:

System Preferences > Security & Privacy > Files and Folders

Find the Zwift app and use the checkboxes.

Reinstalling Zwift is a waste of time and bandwidth. Also, don’t mess with the file permissions, as suggested further up. That’s a terrible idea unless you know what you’re doing (and in that case you wouldn’t use the GUI anyway) and completely unrelated to this issue.

Your credentials should be stored in the keychain. Besides Application Support, there should also be a Zwift related directory in ~/Library/Caches that you’d have to delete if you really wanted a completely fresh start Don’t delete the Caches directory itself, as, unsuprisingly, has been suggested by support on this forum in the past. :man_facepalming:

(I haven’t used Zwift on a MacBook in years, so I’m a bit fuzzy about the exact directory paths.)

thanks guys.
I deleted all of the folders, that I mentioned before, but now before installing the app again I restarted my mac. After the restart, installed Zwift and now it is working again.

Thanks again for your comments.

1 Like

You’re welcome, Adam and it’s great to hear that you were able to get Zwift re-installed and functional again!

Ride On.