Zwift denied access to folders - macOS

Zwift fails to open MacBook Air - it gets so far then pop up window shows error Zwift required access to the document folder, would you like to grant access now - another window asking to grant access now appears - despite granting access, then going into settings and granting access - it still comes back with error Zwift does not have access to the application folder! more than a little vexed with this now, i have followed another thread with similar issues but nothing! this error occured over 2 weeks ago, but as iI was about to start rest weeks I hoped the error may have disappeared - regrettably not any help appreciated before something is launched in frustration!!


If you search “Zwift” in Mac Finder you’ll probably see multiple folders called Zwift, Zwift1, Zwift2, etc First thing you should do is move any custom workout and personal best files out of harm’s way, then delete everything Zwift-related on the hard drive before downloading the app and installing a fresh instance. Step by step instructions are here.

With macOS, when you update the OS, the app security settings get returned to a more restrictive default, and you might have to manually re-allow your apps permissions they might need. If the Zwift app can’t write to the Documents folder, it can’t launch. Repeating this over and over creates the Zwift1, Zwift2 etc duplicate folders. Hope this helps explain what’s happening!

1 Like

@shooj good advice here but i’ve tried this 3x over and still no luck with getting access for Zwift: Zwift even has Full Disk Access now! See screenshots - any thoughts?

Hi @Adam_Towvim welcome to Zwift forums.
Instead of full disk access, please check the Files and Folder access, which is different. See this Apple Support article and let us know if that solves your situation?

thx for the reply! update since i posted to you (and sorry for not closing the loop here): I did give it Full Disk Access but still no dice: I fired up Terminal and made sure that I was in full Admin mode, then it all worked from there. I didn’t go Full Root Access, just Admin. I just googled, “how force macos launch application as administrator”

1 Like