Connection to Wahoo Kickr lost when ride ends and prior to starting a second ride on the same riding session

Trainer: Wahoo Kickr 2018
Computer: iPad Pro
Repeatability: Always

Description: start ride, end ride, then connection to Wahoo Kickr is lost and I am unable to start the next ride without disconnecting trainer and reconnecting.

Hi Paulo,

It sounds like you may be getting some signal drops on the connection or perhaps your Kickr firmware is outdated, and the trainer needs to be calibrated regularly. I recommend trying the following steps:

  1. Check for and update your Kickr Firmware as needed via the Wahoo Fitness app, and perform a spindown calibration. You can find instructions in the Zwift Support Hub article, “KICKR Troubleshooting.

  2. If you’re pairing the KICKR via ANT+, follow the instructions in this article to help you eliminate any potential interference sources.

  3. If you’re pairing the KICKR via Bluetooth Low Energy (BLE), follow the instructions in this article to help you eliminate any potential interference sources.

If that doesn’t help, please submit a support ticket if you haven’t already done so, and one of our support agents will be happy to take a closer look at this matter. Thanks!

The problem may, in fact, be caused by the Windows Update problem. You can do one thing, i,e, update the Windows and then restart the system. You can also check the Windows status. If it is not satisfactory, then reset the Windows following the steps given on Windows update error code 8007000e and get a better service from the system.