Connection Issues in South Africa?

Hi there, is anyone experiencing connection issues?
My Zwift companion app is saying ‘No network’. My Zwift app is saying ‘Couldn’t log in with that account’. Both on Android. And then my Windows app says ‘Logged in but there’s no roads to ride’

Have you tried restarting your wifi and ensuring that you can access internet?

I haven’t used Zwift this morning, but I’ve received notifications from friends who have.

I am facing the same issue. Was able to complete a session this morning, but unable to connect after that.

EDIT: Looks like ISP issue will post back when ISP issue is resolved

Stand by please @Renier_Taute and @Andre I’ve asked our team to find out if there’s a localized problem for your region.

@Renier_Taute @andre and other members in South Africa: we’ve been alerted to a major outage across all ISP’s in South Africa.

Have you two also noticed issues with other gaming plaforms that are highly dependent on low latency internet performance? Or is it just Zwift?

1 Like

Hello, @Renier_Taute @Andre_Kleynhans

Julle weet mos julle kan nie Zwift as Eskom load shedding het nie. LOL

Don’t Zwift while there are Power blackouts. :rofl:


Somethings only a true Saffa will understand.

Hi, thank you fot the feedback. I did not check, but ai am sure it has something to do with that. Streaming movies and general internet browsing worked perfect. I guess welcome to South Africa.


Hi all international traffic has been affected for me, I was able to get around the problem with VPN thanks for the feedback.

:rofl::rofl: Sad but true

1 Like

Also not able to get into Zwift since last night. On PC the error is “logged in but no roads to ride”. South Africa

1 Like

Sorry to hear more members reporting this problem. I thought it might have been a localized problem on Zwift’s content distribution network, but it’s not. Unfortunately, this is outside of our control, and we’ll have to wait for repairs to be made to the undersea trunk lines that connect SA to the rest of the world.

I have been using Zwift for about seven months now and really enjoy the APP. I have had a few ‘dropout’ problems and have tried to navigate around them. This morning how ever takes the cake. I started up my Zwift app this morning on my laptop as I always have and Zwift needed an update . The update was run and from then on I was not able to LOG IN to the Zwift app both on my laptop as well as on my phone to launch a ride. The Zwift app tells me to check the internet connection which is working 100%. Any advice?

@Mike_van_Leeuwen welcome to the Zwift forums, and the discussion already in progress with some of our South African friends.

1 Like

This is really an abomination. I’ve been trying to figure out why I can’t logon to Zwift. I wonder if they’re working on a workaround

Hi @Nosipho_Simelane
I moved your question from its original location because your issue is answered upstream in this thread.

So if I get a VPN.,my zwift should work and bypass this problem?

Have the same issues here, can’t login to Zwift. Saying email and password are not ok.
I can log in with these correct email and password to website but not into the game.
The Netherlands

@shooj Why can my friends zwift while I still get the same issue? I thought this would impact everyone in SA. Apologies my technical knowledge is very limited.

I am also experiencing the same issues connecting since Saturday morning…using an Android device- Johannesburg South Africa

We have the same problem since Friday 17th in South Africa. Haven’t been able to log in since Friday’s update. Tells me “you are logged in, but no routes to ride”. So I can’t get into zwift for the past 4 days.