Connection Failure Whilst Riding

Hi All,

Been Zwifiting since the new year, great experience.

Currently attempting tour de Zwift 2023 however having connection failure issues, is this a common thing and is there anyway mid event to rejoin and continue? I have looked but as yet not been successful in finding.

all rides are long route…

Stage 1 completed fine.

Stage 2 I had connection failure 5km in, on the 2nd attempt a day later I had connection failure 2.3km from the end (waiting for catch up week to complete)

Stage 3 I started this morning however around 3km in the same happened again, pure frustration.

I believe the cause maybe due to BT ‘upgrading’ me to full fibre which has caused me many issues which I didn’t have before the upgrade which they are in the process of fixing, and the fact I am quite far from my router being at the back of the house.

I’ve ordered a ethernet to usb-c adapter today wire my connection going forward but wondered if there was anything else I could do to alleviate this issue.


What happens when the connection fails, e.g. can you carry on riding fine but all other riders disappear and you’re not in the event any longer?

1 Like

My avatar slows down to a stop however I can still see other riders going by / moving on the map until I quit the event.

That doesn’t sound like a wifi/network problem, it has the characteristics of signal interference with the trainer.

Please list a full rundown of your setup, what devices are you using and how are you connecting to Zwift.


Hi @Christian_Smith

What device are you using. It sound like you are getting Bluetooth interference, this can be due to other devices or just a bad usb receiver.

Bluetooth receivers in laptops are very bad. Best to get the Bluetooth receiver close to the trainer.

(I agree this sounds like a pairing problem, but…) If an Ethernet connection improves the situation, it could be due to your WiFi signal interfering with Bluetooth. 2.4GHz WiFi is more likely to interfere with Bluetooth (or ANT+) than 5GHz. 2.4GHz has greater range so if WiFi signal is poor, that might cause a device to prefer 2.4GHz if you are beyond 5GHz range. If that’s what’s happening, installing another access point closer to your Zwift rig could help you stay on 5GHz. Changing the WiFi channel on the router could also possibly help.

Hi All

Thanks for the responses.

My current set up is Kickr core with MacBook Pro for Zwift which is screen mirroring to an Apple TV.

I have 2 tv’s set up one which runs the Zwift via Apple TV and another which I run YouTube / normal tv on.

Lastly I have a myzone heart rate monitor connected to Zwift with my bluetooth on my phone which runs the companion app switched off.

Any help is appreciated.

I would be curious to see if the problem continues if you don’t screen mirror and just run Zwift on the MacBook’s screen. I’m not sure, but maybe that is what is causing signal interference?

Out of curiosity why are you screen mirroring and not just running Zwift directly on the AppleTV? You’ll probably find a much better BT connection with your trainer using the AppleTV to run Zwift.

I am of the belief that Zwift only runs on Apple TV 4K? I have had my Apple TV for a number of years prior to Apple TV 4K coming available hence why I use that.

One other issue I am thinking is that my my zone belt could be interfering, if I am wearing my my zone belt with my phone open the belt won’t be discoverable on Zwift until I turn my bluetooth off on my phone it then becomes discoverable straight away.

I am thinking that it may try and auto turn back on during riding potentially.

Zwift will run on the Apple TV HD 4th gen. Not on the 3rd gen HD model or earlier.

Interesting, not sure if I had mine before this or not but will certainly check when I am home later today to see if it will run directly via my Apple TV.

Interesting. I’ve been using Zwift for about 4 years or so and never had the issue, until I started the TdZ this year.

For me, I get the same connection message at the top but nobody disappears and my guy keeps riding until a short period later the message disappears. The only thing that changes is my position at the top of the leaderboard changes to - -, before reappearing again.

Nothing in my setup has changed in the last 2.5 years. I’m running a Kickr Core, AppleTV 4K (fully up to date) and it’s hard wired into a mesh tower running at 80mbps.

While I’m riding, I have my iPad to watch TV or films - but that also hasn’t changed.

Can’t understand what the problem is!

I had the same issue in TdZ stage 2 on AppleTV. Got the message at the top and my position switched to --. It lasted for a few minutes and happened twice.

What I did notice was the riders up the road and behind me stayed on screen and their w/kg, time ahead/back was constantly updating (as normal). But the group of riders right around me did disappear so it looked like I was riding solo in between two large groups. Soon as things got back to normal I was back to riding in a large pack again.

1 Like

One other thing to add:

Unsure if it’s connected but I noticed my ZwiftPower listed all my power figures as 3.2w/Kg which I know is inaccurate because I was at 6.5-10w/Kg for the final 30s or so. That didn’t happen on the previous stage, though.

Very likely you both encountered TCP drops - TCP is used for non-time sensitive data so is lower priority and will be dropped ahead of UDP (which is used for critical things like rider positioning etc). It’s been reported a couple of times recently wrt that banner appearing without any rider drops or other detrimental impacts. I’m unsure what the cause is (except others have TCP drops in their log files) - usually I’d point finger at a users local environment but Zwift could well have tweaked some things or be “big event” related. I run a packet capture/sniffer device fulltime and have seen nothing that suggests it’s at AWS/Zwift’s end and traffic volume hasn’t changed significantly.

@Ste_Rumbelow your 3.2w/kg thing is based on live data - give it a bit of time to process your fit file and it should change.

EDIT: as you are both on ATV, you could ask Zwift, via support, to tell you what caused the error as they have access to your log files.

EDIT #2 - my comment applies to Ste and James.

Interesting reading, I have also had the — for a temp connection drop on stage 2 but it my ride and other riders stats continued to update etc.

This error my rider comes to a complete stop and I am no longer able to get my rider moving again leading me to quit the event.

Frustrating as each ride now I can’t fully enjoy due to the anticipation that it is going to happen again midway through or at worse on my stage 2 ride 2.3km to the end of the long ride.

Having looked at my ATV, I believe I have the 3rd gen (had it gathering dust for many a year) also so I can’t exclusively run it via that.

I’ve had two crashes in a row the last two days, just after the warmup for my trainer session and immediately before the main block. Fortunately, the TrainerRoad session provided by my coach was running simultaneously on my Garmin 830 so I could continue without interruption, although without the much-needed distraction from the pain provided by Zwift. Yesterday was a VO2Max session and today the inaugural FTP test.
I am running:

  • Waho Tickr Fit optical HR monitor
  • Wahoo PowrLink pedals for power and cadence, per coach’s standard zwift setup
  • Wahoo Kickr Core smart trainer for the controllable
  • OS version:
    Edition Windows 11 Home
    Version 22H2
    Installed on ‎27/‎11/‎2022
    OS build 22621.1105
    Experience Windows Feature Experience Pack 1000.22638.1000.0

Monday’s recovery session was fine - completed nicely.

Any ideas?

You were right about ZP - the figures have updated now. Hadn’t seen that happen before but it probably has!

Would certainly be interesting to see the log files and see what’s going on!


1 Like

I’ve got a very stable setup.

I’m now getting disconnect errors every time.

No loss of any connections and things carry on as normal.