Connection Failure Kick R Core

I use Zwift on a laptop with the latest version of windows loaded.

I have this issue where the Kick R Core shows as connected to Zwift in the pairing screen but does not show power, cadence or speed readings when I’m in a new ride on Zwift.
I have attached two screen shots to show what I’m seeing.

I have disconnected the bluetooth connection for the Wahoo app and Zwift Companion app and no difference.

The trainer will connect to the Wahoo app and show readings without any problems so I don’t think it’s an issue with the trainer.

The problem is only happening via the laptop. It was working perfectly for a long time but I took a two month break where I cancelled and when I returned this week this problem has cropped up.

I have tried all the fixes that come up online and nothing seems to work?

Any help will be greatly appreciated

Try using the companion app as a bridge. You may need to change the setting on the pairing screen as well, the small gear icon in the upper right corner.

Also, power cycle everything even the trainer.

Hi @Frank_Quattrone

Welcome to the Zwift Forums!

In my experience, one of the most common reasons why a trainer will disconnect is due to wireless signal interference. For troubleshooting, see this article.

You’ll also want to make sure the KICKR Core has updated firmware and is calibrated. See this article.

Barring those things and if basic troubleshooting like unplugging the KICKR for several minutes, then plugging it back in doesn’t help, I’d suggest contacting our tech support team is issues persist. You can reach us here.

Thanks. Will do this and post results here


What do you mean by power cycle everything?

Turn things off, unplug

Ah OK, I’ve done that numerous times.

In any case…

A big thank you Mike_Rowe1

Your suggestion of using the Companion app as the bridge worked. It seems to be connecting without any issues now.

Clearly something in the laptop bluetooth setup is not willing to play nice so while I haven’t really fixed that issue I can get around it via the companion app.

Many thanks for taking the time to help.

1 Like

I had a similar connection failure error for my Zwift pod recently and it was caused by my fan being on and creating a field that interfered with my BTE connection btwn my Apple TV and foot pod. Bluetooth headsets can also cause issues.

Here is my post on a separate thread.

Ok folks, I spoke with Zwift help desk and they helped me solve the issue (see article links below). I went through the list of possible interference for BTE and saw fans and headsets listed. Apparently fans create a field around them which can interfere with BTE. I moved my fan to 5 feet away from my Apple TV and not inbtwn me and my Zwift Pod to Apple TV and presto, no more Connection failure.

Also, I used to use AirPods with my iPhone which was also running the Companion app - as soon as I stopped using my BTE headsets, I had no more connection failure issues. I just put a Google nest mini in a plug behind my treadmill to minimize interference and still have music during my run and I can use voice commands which is awesome. The only bummer is this means I won’t be able to use my laptop with my BTE headset while walking on Zwift with the companion app on my iPhone connected to the Apple TV during Zoom calls (as it seems impossible to avoid getting a connection failure msg with all the BTE signals crossing).

I hope this helps!!!


Hi Katy,

Thank you for reaching out to us! My name is Patrycja and I’m with the technical support team here at Zwift. I’m sorry that we missed your chat earlier and you’re having issues with your RunPod but I’m happy to help you.

From what I understand, recently your Zwift pod has started to have connection failures despite being full bars on battery and being shown as connected on the pairing screen, right?

I understand how frustrating it must be!

First of all, thanks for trying to troubleshoot this issue by yourself!

What is more, please check out our article for steps on troubleshooting your runpod.

Furthermore, from what I can see in our system, there are many disconnections and errors in connecting to BLE and this may be the reason why you’re having issues with your RunPod. The usual cause for BLE dropouts is wireless signal interference.

Check out this article​ for tips on how to prevent this from occurring.

Please give these steps a try and let us know how it goes.

Ride On.
Patrycja S
Member Experience Agent