Conflict between Stryd and KickR Core 2018

Yes, by going into run and selecting a power source, you’re basically disconnecting the Stryd

I’ve already asked Zwift to stop Stryd from being available on the Ride menu, where it makes no sense at all. Until they fix that, this is your workaround for the problem

1 Like

Having the same issue. Tried Eirikur’s fix and that isn’t working. Still instantly brings Stryd up before we can do anything.

Same issue. Tried all the work around. But sometimes none of them work and appletv reconnects to Stryd automatically.
Set up bike is Bluetooth connect to cable for power from vector2 pedals and 2nd connection to kickr. I can normally disconnect stryd by going to run and disconnecting then back to ride and connect cable. But stryd will still reconnect kicking my kickr off Zwift reads power from cable but then doesn’t control kickr
Help

Same problem. When I disconnect the Stryd in Run mode and try to select a power source in Ride afterwards, my Apple TV 4K says it lost all bluetooth connection and ask me to use the bluetooth from my phone instead. If my Stryd is in the house, it’s a real pain getting Zwift to connect to another power source.

@MarcAndre_Doucet read my fix / workaround in this thread

Thanks buddy, ride on!

I have the same conflict between Stryd and my Garmin Vector 3S

@Mike_McCarthy1 Could you guys please stop acknowledging Stryd as a Power source for Riding @Zwift … it doesn’t make any sense, since it’s for running-only. This thread is from October 2018 and this issue have never been fixed. Should be very easy to fix!

That would simple get rid of this problem once and for all. There are numerous people complaining about this same problem again and again, is somebody from @Zwift @Jon_Mayfield actually reading this thread??

As I asked previously, in this thread without any answer from Zwift, @Wes

Can you please just stop listing up the Stryd under power-source when you’re on the “Ride” menu …
Stryd should simply never be avilable when you’re riding the bike … simple as that.

You should be able to detect the stryd by it’s unique bluetooth id, and just not list it up for the “Ride” part of Zwift. Please confirm this Zwift and fix the issue once and for all, you see A LOT of people complaining about this issue, which should be so easy to fix if you just put a little effort into it @Josie.L

2 Likes

There are a few other threads in the Zwift Forums regarding this exact issue.
It is not just for Stryd or Milestone foot pods, but also the NPE Runn device as well.
When I used the Milestone foot pod, I would take the battery out of the pod if I wanted to ride. If I wanted to run, I simply unplugged the KICKR.
Since you cannot power off the Runn, my solution was to purchase a Faraday box on eBay to put the Runn inside of, and then I can pair the KICKR without issue.

As I alway use my PC for Zwift I had not heard of this issue until recently. So I tried my best to recreate it. I can get the flicking screen bug, but that’s a simple fix. I cannot seem to recreate the ‘locked in Stryd Power Meter’ bug. If I try to connect more than two Bluetooth devices I get the option to use the Zwift Comapnion App instead and I select ‘YES’. Then I can pair as many devices as I want. To cure the flicker bug I simply swipe the Zwift app off in Apple TV and restart. Obviously guys make sure you have the latest version of Zwift on Apple TV and the very latest tvOS. Make sure you have ZCA open and connected to your network. See if there’s anything in this video which helps. https://youtu.be/imVzBn3qFHw

I’ve tried the force quit of the Zwift app on AppleTV also, and it still would want to connect to the Milestone pod or NPE Runn. It wouldn’t connect as power, obviously, but it was tying up something and would not let me “forget” it.
That’s why I bought a Faraday box to put the Runn in whenever I would change from running to biking on Zwift.

Do you use the Zwift Companion app? Do you ever get the message to use it…as in my video?

I do use the CA. The option to pair through the CA would not show up. I was experiencing was the neverending “flickering” as you call it, even after force-quitting Zwift.
My solution of the Faraday box works for me. That’s good enough.

Hi Dan, I am pleased you have found a workaround for this, but I am still keen to find out why it’s happening, if you don’t ind me bugging you with a few extra questions. Are you using Apple TV 4K or an older version of Apple TV? I assume your firmware is up to date? Have you deleted the Zwift app and reinstalled in? I assume you are on the latest version of Zwift? Is the toggle definitely ON in the ZCA Device Connections tab? Thanks.

+1
I follow and hope that they will fix soon. Same problem with Stryd + Kickr Core 2018. iPad Pro IOS 13.4.
Attila

AppleTV 4k.
I removed the app and reinstalled about a month ago, hoping to solve another problem I had with always being put on the Zwift Carbon bike during the MTB bike challenge they were running that I wasn’t interested in. (it didn’t…)
Everything is up to date on my AppleTV.
I don’t know if the toggle is on, it’s on an iPad out in my workshop, and I can’t get there right now (working).

I experienced this issue yesterday when setting up Zwift on my Apple TV HD, 4th Gen, for the first time.
The connection lock to my Stryd always resulted in ‘No Signal’ to my paired Kickr 1st Gen, the original 2014 model.

When none of the suggested workarounds worked I connected to the Stryd from the Stryd App on my iPhone to prevent Zwift from connecting to it. This resulted in the ‘flickering’ mentioned as Zwift repeatedly tries to connect to the Stryd, which is already connected to another device, and refuses to give up trying to connect. Ended up doing my ride using the Zwift iPad app.

This morning I thought I’d try the faraday cage suggestion and put my Stryd into the small tin case that my Fossil watch came in and put the tin in another room. After restarting the Zwift app on Apple TV, problem solved!

2 Likes

Good news!

This bug I reported on the 20th of October 2018 has finally be fixed! :slight_smile:

I’ve tried to reproduce the bug after the fix and I’m no longer getting this
conflict, the screen no longer flickers!

Well done Zwift :stuck_out_tongue_winking_eye:

2 Likes

@EastCoast_MTBer read my post above, I see you’re asking about the pairing issue on AppleTv, here Game Update - April 29th, 2020

Confirmed. Just completed my second ride with no attempts to lock on to my Stryd, disabling my Kickr!