Computrainer not connecting after update

I use my Computrainer with a high-end Alienware gaming laptop that is about 4 years old. I’ve never had any issue. Last night I updated the Win 11 OS to the latest release candidate. Zwift continued to run fine and all was good.

There was a Zwift update today. Now Zwift will not detect my Computrainer at all.

I reinstalled the USB controller drivers and the FTDI drivers, and they all appear to be fine. I have no hardware conflicts and all looks to be good. Zwift does find my polar HR meter, and my Garmin Vector pedals, which connect via a Garmin Ant+ stick that also is connected via USB, and Zwift likewise finds the devices via Bluetooth (Pedals & HRM). But Zwift doesn’t find the Computrainer that has a wired USB connection.

The Computrainer is found and works fine when I run ErgVideo software, so this looks to be a Zwift issue.

I did uninstall Zwift using Revo Uninstaller, reboot, and then reinstall. Zwift updated itself, and still does not find the Computrainer.

Anyone else have problems? I know it’s time for a new trainer, but the Computrainer has always worked flawlessly and I’ve been hoping to get through the rest of the off-season with it.

Any suggestions would be appreciated.

Exactly same problem. Need zwift programmers to look into this ASAP please!!

I got mine working by uninstalling the last feature update release candidate for Windows 11. From the recovery menu and advance start options). After the previous version of Win 11 installed and the machine rebooted and I was able to get Zwift to pair with the CT, I was able to runWindows Update and install the latest release candidate without issue.

I just want a few weeks more from my 16-year old Computrainer until it’s (a) warmer out, and (b) I can get a new trainer and retire the CT.

Reverted to Windows 10 and it works now.

Also, legacy version trainer road didn’t work with Windows 11 but it’s working after reverting to Windows 10

I’ve become resigned to replacing my CT with either a Tacx Neo 2T or a Wahoo kicker. I’m trying to decide which one, and whether I should wait to see if there are updated machines offered before next offseason. Unfortunately. I have to replace two Computrainers.

Support for Computrainers in Zwift seems like it’s been fading for quite a while now, and is quite limited. It’s been my observation that these older devices are gradually becoming perhaps less compatible with Zwift as time passes, use of newer operating systems becomes the norm, and the game is updated.

As I understand it’s not possible to get firmware updates and the trainers are no longer manufactured. Is the company that makes them even in business any longer?

We have limited resources to get Computrainers working in Zwift, which can be found in this article, but that’s about the limit of what I know.

2022-03 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB5011487)

After Windows 10 installs this particular update my Computrainer is not found by Zwift. I’ve gone through and updated the FTDI driver and checked everything else that I could think of. I don’t have the Computrainer software loaded on because i don’t use it, but there are no errors in the device manager and it works prior to and after I roll I back to before that Windows update. I’ve had to do this several times now because I didn’t block Windows from updating it. I figured it would get fixed by now. It’s been a problem for months now. I wish this would get fixed so I can spend my time riding instead of doing System Restores.

2022-03 Cumulative Update for Windows 10 Version 20H2 for x64-based Systems (KB5011487)

This Windows 10 update killed mine too. After I System Restored to before that update it resumed functioning. I’m not sure what to do as the hardware is fine, but Zwift and Windows aren’t cooperating. I tried updating FTDI drivers and everything else. There are no problems showing in the Device Manager.