Pairing to Computrainer


(* Trisaffa (Trifactri)) #1

I am unable to run Zwift with my Computrainer. My Computrainer runs fine on Comm Port 3 with the Racermate software suite as well as Trainerroad. I always connect my C trainer, then run the coaching software to ensure communication is good between my trainer and my computer.

I then shut off the Racermate software (unless I am using it) and run the alternate sofware with no issues (Trainerroad generally).

When running Zwift, the software searches for and finds my Ctrainer, then pairs with the trainer. Immediately thereafter, it gives a “Connection Lost” error, and I am unable to reconnect.


(Ron Skinner) #2

have you tried removing the usb connection then reinserting it? Sometimes when one program grabs the usb port it may be unstable after you shut it down. I know on my windows computer racermate does not always stop the racermate process when you close the racermate application. If you go to Windows task manager you can see it is still running and can close it there. Just a thought, so far I have not had any CT issues with Zwift. I have done a 10 minute warm up, closed racermate, opened Zwift and it paired OK. Have not tried this with latest build though.


(Doug Goglia) #3

Do you need to run the coaching software? I would assume Zwift would ID the proper com port and find your Computrainer.

I leave my Computrainer attached to my laptop, and never power down the Computrainer, so all I have to do is pump my tire (dedicated bike) to 8 bars to get pretty close to the same calibration no. Each time (I try to keep it at around 2.75). I usually start my workouts using Ergvideos, and calibrate after 12 minutes before doing the Ergvideos intervals… When I shut down the Ergvideo app, I can start Zwift without any problems.


(Jimbo Solvang - (62)) #4

John:

Have you submitted a request directly to Zwift? I had issues with my Computrainer hookup and received a quick response.

Are you running Windows or Mac? I have both platforms. I had big issues with the Mac crashing last week which are now resolved with the latest upgrade. 


(* Trisaffa (Trifactri)) #5

Thanks for feedback. I don’t need to run the Racermate software, I just use it as a check for occasional connection issues with Trainerroad or Erg Video. Generally, they connect perfectly every time. When running Zwift, I get a perfect connection initially, then the connection gets “lost” within the first minute and I cannot reconnect. Will try direct query with Zwift

 

 


(Jim Dockal WBR) #6

John, I have been using Computrainer Pro with RacerMateOne software all along. I do the 10 minute warm-up/calibration run and then shut down the RacerMateOne software and then kick in the Zwift software and login, never a problem. Are you using the old Computrainer to computer hook-up or the newer one with the fancy led blinking? 


(Doug Goglia) #7

I keep my CT powered 24/7, and calibrate at the end of my rides, with my tire inflated to 8 bars.  I then re inflate the tire to 8 bars before every ride. (I have a dedicated bike on my CT).    My calibration stays the same so long as my tire is inflated properly.

I would like to see a way to pause after warming up in Zwift so I can do a roll-down, but I have no problem keeping my CT powered on.


(Jimbo Solvang - (62)) #8

Doug:

Do you deflate the tire after every ride? I once forgot to undo the tension on the rear tire after a ride and 2 days later when I started to ride the tire was deformed and had a flat section until it warmed it.


(Doug Goglia) #9

I deflate the tire partially so it doesn’t deform and keep the tension constant.