Not finding Computrainer after finish & return. Windows


(Todd Busteed ABD) #1

I’ve seen info about Zwift hanging on to a USB port after establishing connection and wonder if this might explain why…

  • When connected, finish a ride, exit app.  Return to app immediately, and Zwift can’t connect to Computrainer.  

  • Ant+ animation in upper left corner of connection screen does not flash when pending connection won’t work.

  • Was common after Zwift updates.  Now quite regular.

  • Restart does not solve problem.  Power off, power up does.

  • Windows 7 Premium.  Hardwired Computrainer, Ant+ Garmin HR 

 

Anyone with insights?  Solutions?  Used to be able to “sleep” machine and wake to working Zwift.  Now rebooting 50% of the time.

Thanks!


(Jason K) #2

We had a similar problem in the lab recently, but updating the drivers solved the issue - see our Computrainer KB article for a link to the driver. Even if you have the correct driver installed, it may be prudent to uninstall and reinstall the driver, as it could just be corrupted.


(Todd Busteed ABD) #3

Thanks Jason,  Unable to update the drives listed in the KB article as Windows returned a “…did not update any of your software… because it is not better than the software you currently have installed.” message (unusual wording…)  The version numbers are higher and the release dates later on the newer drivers.

Deleted the two FTDI apps in an effort to get newer drivers installed but that appeared to have no effect.  Same message.  Can you tell me where the drivers are actually located?  Not showing up in a search.  Assuming they need to be deleted to be updated?

For now, there’s always rebooting, but a shame after months of “wake and go”.


(Todd Busteed ABD) #4

In the event others are chasing down a similar issue, “Answered” does not mean “Solved”.  The problem persists.  Submitting ticket next.