Completed Uber Pretzel but did not get badge/XP

I completed the Uber Pretzel today but didn’t get the banner at the top of the Alpe, nor did I get the badge or XP. I kept going to do an imperial century, so the distance wasn’t the issue… I didn’t touch any of the direction options, so I definitely did the route. I restarted Zwift a couple of times to see if it popped up when I reopened it, but no luck. Is there anything that can be done? Safe to say I’m not particularly keen to do the route again any time soon… Brutal. What I presume to be the activity ID (the last bit of the activity URL) is 633259506536135088.

That activity Id was very helpful.

Something seem of with the activity, look how the gps does not follow the map?

image

1 Like

Yeah I saw that as well… My guess was that the route line only displays a certain number of points per ride, and since it was a long ride, the points were more spread out? I definitely stayed on the roads the whole time…The data is definitely there - the Strava activity looks correct, with no cut corners like that.
The Strava activity ID is 4023101795, it should be public (collected the ID in the same manner as the Zwift activity ID).

1 Like

Does anyone know how Zwift determines course matches?

I assume routes are parameterized (road ID, direction), and it keeps track of when you reach a node, at which point it sends you to another (road ID, direction) unless you over-ride. Along the way are “events” which can be triggered, like crossing banners, which are associated with a given position on each road. If you trigger both the starting and finishing events, you did the route.

I wouldn’t think there’s any internal consideration of GPS coordinates. There’s no free-riding in Zwift.

If you turn off the route, then back on, you broke the chain of events, and you don’t match the route… or so I would guess.

A lot of people have matched the segment today. It would be interesting to ask them on Strava if they got the badge.

1 Like

For what it’s worth, there is another thread going on where the general consensus seems to be that Zwift isn’t awarding ANY badges since the update last Thursday.

1 Like

Interesting… I did get other badges though - the 100kph coming down Radio, 5x Alpe, metric, and imperial century. Maybe it’s just route badges?

I guess I should have said ‘route badges’.

I had this problem today. Contacted support and sent my log files. The agent said they have flagged this issue to upper level support but there isn’t anything to be done at this time. No admin tool to fix the issue or grant a badge. Kinda sucks cause at my pace, 6 hrs and no badge feels a little wasted, although at least the garmin sync worked.

1 Like

I got PRL Full on Saturday, so it isn’t an issue with all route badges, but there sure seems to be a pattern since the latest update.

That site also lists the amount of lead-in and extra elevation you have to do to get the badge. I learned pretty quickly that you just have to keep riding sometimes to get the badges.

Yeah I got a couple of route badges too after the update (on AppleTV). It does seem, due to the number of reports, that something’s up with route badges on the current version - certain routes, perhaps?

Not with the Uber Pretzel. That one is basic: start the route, finish at the top of the Alpe.

Welcome to the club. :frowning:

Route completed. No xp. No badge.

I rode 166 km. I received the 100-mile reward, but nothing else. I thought the route take me back to town and it would end there, but it led into the jungle again and again.

631705954224735264

1 Like

Same here. I finished the Uber Pretzel earlier, my last route badge. But no badge. I could cry. Took me over 6h. I have the same weird looking route trace as mentioned above. Can’t believe that this has anything to do with any internet drop outs? Please please please Zwift take pity on us and give us the badge?

1 Like

Had the same bug on Uber Pretzel this Sunday((
Also you can find same thread regarding Four Horseman on this forum.

1 Like

I really hope they come up with something, seems like a lot of people are getting hit by this. Can’t be that hard to set up a job to scan all of the activities since the release to correct the ride trace and retroactively give badges…

Like others I completed Uber pretzel today and was not awarded a badge. After almost 7 hours my poor legs feel like they are broken and I don’t think I can face it again.

The activity ID is 633808235928848096

I know this topic has probably been done to death but I’m hoping that a rep might note all of the topics and do something.

3 Likes

Same issue, seems to be really wide spread

Id: 633828405497930320

Hello!
The same happened here. I have no hope that Zwift will solve it. Months ago the same problem occurred and Zwift’s answer was: we can’t do anything.
Best regards,
Jadson

Did The Uber Pretzel on 5 Sept, no badge. Redid it again on 6 Sept, still no badge! Frustrating for a subscription paid platform. The least that should be done is for Support to let us know that there is indeed an issue, post a warning about the issue, let us know when the issue is solved. The silence is unacceptable