Companion won't put me into the ride

I sent a support request awhile ago but Zwift isn’t responding. For the last 6 weeks, Companion Home button won’t put me into the ride. All the other functions work. Before, it put me in, took me out, put me back in. But now, it isn’t putting me into my ride at all. My game functions fine on my laptop- no drop outs of any note. But the Companion issue is persistent. I’ve removed the app and reinstalled to no effect. No idea what else to do. Thanks

You mean the ZCA game map isn’t loading, or the icon isn’t showing up under the HOME button? Make sure both your laptop and whatever is running your ZCA are on the same wifi network. Myself, I have to make sure they are BEFORE I launch the game, and if that still doesn’t work I have to go into app settings and force stop ZCA and restart it.

Yes the ZAC map isn’t loading and I only have one wifi network so it always runs on the same. I don’t know how to force stop ZCA and restart. I already deleted the app and reinstalled. Do you mean turn off and on? I’ve done that many times to no avail. Today it showed me the map for 10 seconds and the disappeared for the rest of the group ride.

Generally, when the map isn’t loading it is an indicator that your phone is not on the same network as your Zwift game session. This might just mean (as you say that you only have one network) that your phone just isn’t getting a good WiFi signal and is, therefore, switching back and forth between WiFi and cellular data. So, you might try turning off WiFi assist, or just turning off the cellular connection while Zwifting.

Another possibility is that you are running a WiFi mesh network. These can sometimes present issues as each node might be assigned a different address, thus confusing the connection between the game and ZCA.

Just a couple of thoughts. I hope something helps.

Do you have ZCA location allowed(when program running) in settings/apps/companion?

I can’t see where location allowed is in the app. I don’t see it in settings

I don’t have a mesh network. I’ve also turned off wifi to no effect. I don’t see any wifi assist but I don’t think I turned that on

I don’t see that as an option

Sorry my bad, I should have explained more, it should be in your device settings. For example. I use an Android tablet for ZCA, so location permission is in settings/apps/companion

Thanks Jason. I don’t think I have that. but I have turned on wifi in my general settings on my phone for companion.

Don’t turn off the WiFi, turn off the cellular.

Honestly, I’ve tried everything. During the ride, I turn off Wifi and it doesn’t force the ride to show up. I’ve tried Bluetooth, wifi… I don’t know where Companion connects but I have tried turning different things off. Nothing seems to work. I wonder why it would come on for a few seconds and go off. Sounds like connectivity issues but then the rest of the app works as do other apps like Discord.

I’m not technical enough to be able to help with your phone/CA set up.

But as a thought or alternative option do you have an IPad onto which you could download the ZCA and try that. I find phones way too fiddly and small and for me IPad and Laptop works well.

Thanks no IPAD. I just wish support would get back to me. But I appreciate your help

Turning off wifi is the last thing you should do, because it’ll only work if uout phone can see the Zwift game device and your phone needs wifi to do that.

Have you tried rebooting your home router?

The problem is your phone not being able to communicate with your Zwift game device over your home wifi, for whatever reason.

Another thing you can try is putting your phone into airplane mode and then turning on wifi.

What I’m wondering, Steve, is why the rest of the app works. I don’t understand the tech side of the app. I will try airplane mode… Thanks. I’ll report back.

Another thing, though. If I go to airplane mode, will Discord work? Does that use wifi?

Most apps aside from calling and basic messaging should work via wifi only.

If turning on Airplane Mode and then turning Wifi back on doesn’t work, it’s possible there’s some sort of router configuration that’s blocking the companion app from talking to Zwift

If you go into airplane mode AND then turn on wifi, then yes, Discord will work fine. You can also turn on Bluetooth if you are using Bluetooth earphones with Discord.

Do you know how I could check that? It worked for years so I wonder why now.