Companion not syching with my workout?

I run Zwift on my MacBook Pro and have Companion on my iPhone. Before the latest iOS phone update, when I was riding or doing a workout, I could see the map on Companion, see the workout on the workout page and see and send messages. Since the latest iOS phone update of Companio, this isn’t happening. The Companion app knows it’s me, the Zwift app running on my laptop is doing what is expected but Companion looks as if I’m not riding (no map, no workout screen…). I gave it a few days just in case there was some latency issue with the update, then I deleted the app on my phone and re-installed it but as of this morning, it’s still the same issue.

Anyone else having this issue?

This is most commonly caused by the iPhone and Mac not being on the same network. The iOS WiFi Assist feature can trigger it, although that should only happen when your WiFi signal is very poor. You can disable that feature on the phone.

You can also try putting the phone in airplane mode and then manually turning WiFi back on, so it never uses the cellular data service.

If you have a dual-band WiFi router, that can also sometimes cause a problem if the iPhone and Mac are on different bands. A solution to that would be to rename the 2.4GHz band so that it doesn’t share the same name as the 5GHz band. You should prefer 5GHz unless your WiFi signal is poor - 2.4GHz is slower but has better range.

Thanks for getting back to me.

It would be odd that my phone is experiencing weak WiFi. My cycling set up is only feet away from the modem with only air between me and the modem. There is fibreoptic cable to the modem. This has never happened before but I have turned off WiFi assist just in case it’s the culprit.

Best of the season to you and yours.


If the modem has an extra Ethernet port, you could also try connecting the Mac to it that way.

Otherwise, I would work on ensuring that you’re using different network names for 2.4GHz and 5GHz WiFi bands on the router.

Thanks but this is getting out of this old-fart’s technical range (other than the ethernet cable).

I’ve been Zwifting for a few years now (3?) and this is the first time it’s happened. If it happens again, I’ll investigate the multiple network thingy as my first line of enquiry but I’m confident that we won’t go through this again.


Have you already rebooted everything? Phone, Mac, and modem? That’s a pretty easy step you could take, and it does sometimes help.

ha ha!

I worked in technology before you were likely born. Application development (big national government systems stuff, big iron) not hard core technology down in the bits and bytes. The first thing I learned about technical glitches was to reboot everything and see what happens. That was step one. I also uninstalled and reinstalled the app a couple of times.

Not sure if you received an earlier reply from me but the problem seems to have been resolved somehow. Companion worked as expected on Tuesday and this morning so I am chalking this up to some weird gremlin that got into the works and sorted itself out. We had a term for that back in the old days - FM. I’ll leave it to your imagination to interpret that as you wish.

Hope your day goes well.


1 Like

Playing the age card! :joy: I spent about 30 years supporting data centers and software engineers. I can’t tell you how many times I’ve seen brilliant and experienced PhD level computer scientists fail to do basic debugging, so I learned to assume as little as possible. I hope it remains stable for you.


Yes, I would agree that it’s safer to suggest the reboot than assume they would automatically. Good to know that there is some solid experience on the team. Nothing beats well earned scar tissue.


I just took a close look at your avatar. A cyclist on Zwift! I’m there too in the winter but a the back of the pack. Can’t even hang onto a blob during Tour de Zwift.

Ride On!

D’ho - just realized I was replying to a ZWIFT support message. Of course you Zwift. Thought it was another one (various issues abound at this time of year).

Carry on.