Companion Map won't stay loaded

Companion keeps defaulting to the Home page. It says the map is loading and it will load for a little while. I try to take photos then but I have to be quick as it usually goes back to the Home page. Any ideas? I have my iPhone XR mounted on my bike to access Companion. I run Zwift on a MacAir with an Elite Quobo Smart trainer

Had the same issue and solved it by stopping mobile data. Just for the duration of the Zwift session. I guess the phone defaults to mobile data when WiFi is weak. Which is my case. Hope this helps!


You can change this behaviour without disabling all mobile data every time, it’s called smart network switch on Android and Wi-Fi assist on iOS.

1 Like

Normally, I would have to agree with you, but WiFi assist on my phone is (was and will be) always « On ». Nevertheless, the only way for me to enjoy (durable) companion functionality Is to stop « mobile data », the time of my Zwift sessions. FWIW

That’s what I mean, turning that feature off stops your phone from hopping about networks. If it’s more convenient to turn mobile data off each ride then yeah just do that. :+1:

Annie, would be interesting to hear whether this solves your problem …

Hi @Annie_Simmons welcome to Zwift forums.

The smartphone running the Companion App and the computer running the Zwift game app have to be on the same WiFi network to see each other. The sort of issue you’re describing can happen if your WiFi signal is flaky

There are some other helpful ways to improve issues with Zwift Companion on our support hub.

Hi Shuji

They are on the same WiFi network. There’s only one at home.
Initially I had problems with drop outs on Zwift, but my phone
was OK, and I thought it was an internet problem (as the phone
could use 4G). However I noticed that if I tried to access Zwift
message from Zwift saying to turn Garmin Express off as it could
interfere with Zwift. I always turn that laptop off now when
running Zwift on the Mac downstairs and I don’t have any problems
with drop outs of Zwift. I thought it might have been something
simple like that.

I’ll check the support hub and maybe try turning off celluar data
on my phone so it always has to use WiFi. (Although normally it
does when I’m at home)