Companion app doesn't work at work

Right - not a huge deal here but I’d like to have everything working.

To entice us all back to the office, my noble employer has made a nice fitness center with 3 Stages bikes. I have a little iPad Mini (the most recent one) to run Zwift, and that works great connecting through my employee login on wifi. However, the companion app on my phone (a Pixel 6), connecting through the same wifi network, doesn’t recognize that I’m riding, and so doesn’t show a map or controls.

I haven’t tried the same setup at home with my kickr 18, as I have a dedicated PC and TV for that getup. That works fine with the companion app.

Any ideas? A security setting in the iPad? Something locked by our IT team?


My guess would be something weird with your work wifi (that’s the technical term!)

if you’re able to, and have a decent amount of mobile data, if you hotspot off your phone that will work

I’m not sure that it does work. Any time I’ve hot spotted off my phone to run Zwift the companion app won’t recognize that I’m riding.

1 Like

It is probably ports that are blocked by IT. there is a list out here somewhere that has all the posts that need to be open,

EDIT: See this post Document required ports used by Zwift

Actually you may be correct - i use a different phone to hotspot both the pc and the phone running the CA from

Perfect, thanks! Solid chance that I won’t be able to talk the powers that be in to opening those ports but I can ask…

1 Like

Update: confirmed that it’s the ports and the IT folk won’t open them up. More interestingly the guy who responded to my request was a Zwifter so I didn’t get a dumb canned response!

Thanks all…

1 Like

It’s possible you might be able to use the Pixel as a WiFi hotspot (using its cellular data connection) and have the iPad connect to the Pixel hotspot. I’m pretty sure that does not work in the reverse scenario (using an Apple device as the hotspot) but I’ve heard that it may work using the Android device as the hotspot. I have not tried this.