Club set to ‘none’ each login

Each time I log in to Zwift my club is set to ‘none’.
I pick my club and it’s good for One session. If I leave the ride, I have to do this again, and again, and … it does not shave the club for Some reason.

I’m on board with this too.

End of every ride, you have to click the drop down to select a club.
Why can’t it be saved from the previous entry?
(And why can’t I save a ride to multiple clubs?)

In the same vein, the Tron bike.
I pick the Tron and select the colour to match my kit.
Later, I select a different bike for a different activity but when I go back to the Tron, I have to faff about again getting the colour match with my kit.

Annoying!

Just leave the settings where they are and let us change them if we want to, not because we have to.

Clubs aren’t an option you can even choose if you’re trying to save from the Companion app.

That means I wind up moving to my Mac and saving there. It would be better if I could choose one on there, and for it to stick as in this suggestion.

1 Like

This “not defaulting to your club” thing has been around for quite some time. I’m sure we were told it was going to be fixed, but I don’t know why it’s taking so long (given that it initially used to work fine).

Edit - according to Clubs Update: June Recap it was supposed to be fixed in 1.29, so we’ve had three releases that still haven’t fixed it.

Each time I log in to Zwift my club is set to ‘none’.
I pick my club and it’s good for One session. If I leave the ride, I have to do this again, and again, and … it does not shave the club for Some reason.

1 Like

i’m hoping this is coming with the next clubs update. Clubs Update: June Recap - #25 by Olivero

Seems simple it used to work on the old UI