Can't connect with companion app

I’m using machine translation, sorry if I’m judging properly.

I played Zwift for the first time yesterday.
I fixed the fitbox gate, which is a cadence sensor, to the fitbox, which is an exercise bike, and connected it to a PC via Bluetooth.

I found out that there is a companion app and tried to install it, but it doesn’t work.


According to this page,
“The PC running Zwift and the iPhone running the app must be on the same (WiFi) network.”
There was.
I’m probably not good here, but I don’t know how to check that they are “on the same network”.
Is there a setting method or a confirmation method?

The IPv4 address of the PC is
The IPv4 address of the Wi-Fi in use on the iPhone is
I think it’s

By the way, yesterday I played a game with Bluetooth, but when using the companion app,
I don’t use Bluetooth connectivity, do I?

If the companion app is available,
Does the upper left part of the attached image show some kind of reaction?

I will wait for your reply.

Hello Taro and welcome to Zwift.
To answer your last question first: no, there isn’t any reaction visible on the pairing screen if the Companion app is working and on the same network. That option at the top left of the pairing screen is for using your smartphone to act as a ‘Bluetooth bridge’ for connecting sensors to Zwift, but since you have managed to connect the speed sensor and the cadence sensor directly, you don’t need it.

And no, you don’t need Bluetooth to sync Companion, just Wi-Fi.

What smartphone are you using? iPhone? Android?
(If you’re on an iPhone 14, you may be running into a known but rare situation where the device is just unable to sync/connect. Let’s hope that’s not the case.)
Often, the inability to get Companion to sync with Zwift is due to the smartphone switching to using cellular data instead of Wi-Fi, even though Wi-Fi is selected. You need to go into the smartphone’s main settings and make sure that the device doesn’t have the possibility to switch to cellular data (often called ‘cellular assist’). For initial testing purposes, you could also just disable the smartphone cellular data altogether by going into Airplane mode and then activating only Wi-Fi.

If your Wi-Fi router is dual band. it could also be that your zwifting computer is accessing one band while the smartphone is selecting the other. These are often 2.4GHz and 5GHz, but I don’t know what part of the spectrum is used in Japan. If you can, limit your Wi-Fi router to only operating on one of the bands, or else check your PC and smartphone settings to see if there is a way of making sure they’re definitely on the same one.

When your Companion does finally sync when you’re running Zwift, it can take quite some time – up to 20 seconds on my phone, sometimes – for the connection to show on your phone screen. Just keep Companion open and wait. You should see a map appear, and the options at the bottom of the screen also change. If mine doesn’t connect after 30 seconds, I ‘hard close’ Companion and open it again.

You may find some other useful things here. (Unfortunately, this page doesn’t seem to be available in Japanese.)

Good luck and let us know how things are going. Ride On! :ride_on:

Thank you for your kind reply.
But the problem is still not resolved.

The fact that you don’t need bridge mode means that Connect my computer and bicycle with Bluetooth and start the game, Is it correct that the iPhone works as long as it’s on the same network?

My router is dual band, 2.4GHz and 5GHz are selectable.
But I forgot to tell you something important.
The PC is wired to the Internet and does not have a Wi-Fi function.
The iPhone is connected via Wi-Fi.
I understand that the companion app is still available in this case, am I wrong?

I thought about it based on the following pages.
However, ping transmission is not working.
Also, I wasn’t sure about telnet.
Also, this article is quite old, so I thought it might be better to ask a new question, so I created a topic.

Other things I checked:
I’m using iPhone SE2, so the iPhone 14 problem doesn’t seem to be relevant this time.
I turned off mobile data communication, turned off Wi-Fi assist (≒ cellular assist), and turned on airplane mode.
I have rebooted my modem and router several times.
The ability to create homegroups seems to be a deprecated feature now.

Sorry to read that this hasn’t sorted itself out yet.

It sounds like your iPhone settings are all good.

Yes, in this situation you only require Bluetooth for your Fitbox Gate to communicate with your PC.

And yes, according to Zwift’s support pages, you should still be able to sync Companion to Zwift if your PC is connected to the internet via an Ethernet cable, as long as your iPhone SE2 and the PC are accessing the same network path.
Unfortunately, I don’t have experience of having to do that with an Ethernet-connected device. I’ve seen another thread on this subject that mentions some modem/router set-ups “not allowing traffic between ethernet and the wifi slots”, but I’ll admit I’m out of my depth in this area.

If this isn’t easily resolvable and you want to continue using that PC for Zwift, it might be worth investing in a Wi-Fi USB adaptor for it. They aren’t prohibitively expensive, generally.

In the meantime, for testing/elimination purposes, do you have access to a Wi-Fi enabled device like a laptop or iPad, on which you could run the main Zwift game, to see if Companion syncs up in that instance? (Making sure, of course, to log out of Zwift on your PC first.)

One other thing came to me: are you definitely logged into Companion on your phone using the same Zwift account as the one you are logged into on your PC?

thank you.
After all, I should be able to use the companion app even if my PC is wired.
However, in my case, it doesn’t go well, and it seems difficult because I don’t have enough knowledge about the network.
Sure, it might be easier to buy a Wi-Fi adapter.
Unfortunately, I don’t have an iPad or other device, so I can’t test the companion app.
Next time I will ask my friend if he has an iPad.
The account is definitely the same account on the PC and the smartphone.
Thank you for taking the consultation.

1 Like

Basically your phone and your Zwift game device both need to be able to see each other on your home network. It shouldn’t make a difference if one is wired and one isn’t, but different routers have different setups for this sort of thing so it’s impossible to give a definite answer for your setup. I would try rebooting the router if you haven’t already done so.

Good news! ! I was able to solve it!
The problem was in the router settings.
Among the security functions, there is something called “quarantine function”, and it seems that communication was not possible because of it.
(Depending on the manufacturer, it may be called “privacy separator”, “network separation function”, “AP isolation function”, etc.)
I turned this off and the companion app worked!
Thank you for hanging out with me!

Thank you for your reply. I rebooted the router several times, but it was all due to security settings in the first place.

1 Like

Great news! Happy zwifting. I find Companion very useful during rides, so this was worth it. :ride_on:

1 Like