Zwift on PC with Ethernet and ZC on Phone on Wifi

Hi, I am having trouble connecting my Zwift Companion app on my phone and my Zwift app on my PC. My PC is connected via ethernet cable to my router, while the phone is connected to the same via WIFI. Anyone have the same issue?

I run my ATV via ethernet and my Companion App on my phone on the same wifi network - no problem.

Does it work ok when your PC is just on wifi?

I dont have a wifi card on my PC so I cant try it, unfortunately.

I use this setup with no issues. Ensure your phone is configured to only use WiFi for data, rather than both WiFi and cellular. On Android this is called Smart Network Switch, on iOS it’s WiFi Assist.

I just tried turning off my mobile data and still doesnt connect. Thanks for the suggestion though.

I also have the same setup and it works without problems. Is it possible that you are connecting to a “guest” network on your router? These are normally configured to isolate traffic from the rest of the network.

What is the IP address of your PC? What is your IP address of your phone? It is ok if they are on different subnets as long as traffic is allowed between them.

You could try statically assigning IP addresses to both devices and see if that works. If that works you might have to see if your router can do DHCP reservations so you wont have any issues using different WiFi networks with your phone.

I have been running that setup for years without issues.


I had the issue that even on different subnets and traffic allowed, it would not work, it was not until the PC and Phone were on the same subnet did it work for me. Based on my pfsense firewall, the app was not even trying to contact the other subnet, my PC.

1 Like

Based on research, I actually think it is my network providers router that is not allowing traffic between ethernet and the wifi slots. I have the same problem with printing on our wifi printer from my ethernet PC. Thanks!

How is your router set up? Does your ISP router let you do VLANs / separate subnets for wired vs wireless?

When I check network on ATV it simply shows “ethernet”. How to make use SSID for Companion matches the ethernet network name? (My wireless is via an access point connected to the router, btw)


My post wasn’t to do with Apple TV. This thread is about PC, and I was talking about a change you make on your phone. :+1:

You are basically talking about 2 different things. When it says “ethernet” it is just a name for your wired connection and will not match the wireless SSID.

1 Like

Did you ever get a resolution to this? Mine was fine until last month then I now have this issue.


also interested in this, i was running my PC and companion app on WIFI but the wifi connection was not stable enough so i connected the PC through a hard cable and now the companion app will not show active sessions,

It works fine, the change to your setup must have resulted in the PC and app now being on ‘different’ networks, even if the incoming/original internet source is the same. This can happen a lot on mesh Wi-Fi.

1 Like

i do have mesh wifi, i just tried unplugging the hard cable and connecting both to wifi, it works fine, as soon as i plug in the hard cable again and disconnect wifi the game feed is lost. any ideas how i get them to communicate again, you are talking to an internet dummy :roll_eyes:

It’s because mesh effectively replaces your existing router - whereas with an ethernet cable your PC is connected directly to the router. So as far as the Companion app is concerned, your phone and PC are on different networks when the latter is hard wired.

Look up the manual and see if you can change the mesh system to access point mode. I don’t know how this will affect the performance of it for the rest of your home. The other option is to try and improve the Wi-Fi reception on the PC.

thanks for the reply, that is quite irritating, i upgraded the wifi to mesh because it was unstable and not providing a good signal across the property especially when trying to work home office, when this was also not quite good enough to supply the pain cave and keep zwift from dropping out i routed in a hard cable. could i use the old router to create a seperate wifi connection in the pain cave to connect PC and Mobile phone on same network?

other option is to add another mesh point closer to the PC to improve signal strength