Calibration for Wattbike Atom

It is not a workaround, Zwift does not know what resistance you need for your the 20min FTP section. If you a lot stronger than last time you need more resistance and when you lost fitness and power you need less.

The Ipad should have the menu at the bottom, so you can use that to change resistance.
So you need to adjust it to fit you specific needs.

I still can’t get this to work. As soon as I hit the 20 min free ride the cadence resistance disappears. I’ve tried to increase the resistance with the +/- buttons, the up/down buttons and the gears on my wattbike but none of them make any difference to the zwift workout. I love everything else about my Wattbike/Apple TV/Zwift setup - just wish I could get the workouts working properly.

1 Like

That is strange , did you see the orange bar move up and down in the top of the screen?

Try a workout with ERG off and see if you can increase the resistance manually

can’t say I noticed the orange bar Gerrie - I’ll give it another go with ERG off in a couple of days

Give it a try @Dave_Dorward

You can use any workout to test, just turn off ERG and play with the buttons.

I don’t have a Wattbike, that picture is with my Saris H3 but it should work the same.

Good luck.

:ride_on:

1 Like

Having this issue myself since switching from my computer to using the AppleTV. Somewhat makes these free ride workouts pretty pointless.

1 Like

Please see this thread where I’ve done some AppleTV and Wattbike tests. It still doesn’t work when switching to free rides in a workout, erg mode is not turned off no matter what buttons you then try and press on the AppleTV or the wattbike. Come on Zwift fix the AppleTV app for us

1 Like

This is still an issue, 18 months after first reports grrrr, just wasted an hour’s workout, back to the iPad for workouts it is then.

1 Like

@Gerrie_Delport I did another workout this evening & once again all was well until I hit the freeride section when resistance disappeared & all I could do was spin out whilst generating virtually no watts.

Even switching out of ERG mode & using the up/down arrows via the AppleTV remote made no difference despite the orange bar moving up/down.

Reminder of my setup: Wattbike Atom, AppleTV 4k 32gb, Zwift app (latest update), iPhone 8, Companion App (latest update)

Can this bug please be escalated with the Zwift development team?

O no Dave,

I would have hoped that that would solve your problem, Usually the up/down change the base resistance when ERG is off.

Can you pick any workout, turn off ERG and see if the up/down make a difference.

Hello

I have the same problem.

My set up;

  • Wattbike Atom
  • Apple TV 4K
  • Zwift companion on iPhone X

(All on latest firmware etc)

The 20 min warm-up section of the “FTP Shorter“ is fine, but come the 20 min free ride, I can spin at a cadence of 120-130 and only generate power about 100W.
Likewise I can spin slowly, but will still generate a similarly low power output.

Using the companion app, I have tried to toggle off ERG mode. I can get it to display climb / incline mode, but this makes no difference. The mode I suspect I need is Gear Mode, but I can’t locate it.

I’ve tried using the gears on the Wattbike, but they are redundant.
I’ve tried changing modes via the Wattbike’s controls, but they don’t work either.
The on screen controls via the Apple TV remote don’t seem to do anything that solves the issue either - not that I want to be messing around with this during an FTP test.

When using the Atom during a normal ride on Zwift I can change my gears to affect the cadence / power etc and when I do so, I can see my gear numbers changing on the top left of the screen, just below an information box. This is what I would think is needed for the issues being raised in this thread.

I’ve raised this with customer services / support at Wattbike and they tell me this issue should be taken up with Zwift.

From their website, Wattbike are one of a limited number of trainers that have ‘Zwift Certification’.

This suggests the two products should work together without any glitches.

Having recently bought the Atom and tried to do a virtual FTP with a group of friends, I feel a let down that such a simple issue exists. Should Wattbike have ‘Zwift Certification’?

I suspect having Zwift Certification is good business for Wattbike and Zwift - although a little misleading for potential buyers if such simple glitches exist which aren’t getting fixed - even when raised a long time ago.

1 Like

It makes no difference Gerrie - and as you can see from the other posts in this thread this is a common issue & has been ongoing for a considerable amount of time.

FWIW - I also subscribe to FULGAZ and their platform integrates perfectly in both ERG & FREE RIDE modes so I don’t believe this is an issue with my Atom.

Where does this ticket sit on your dev team’s bug backlog?

I’ve conducted 3 tests this evening in an attempt to identify the issue.

First off, I created a custom workout; 2 mins warmup, 5 mins free ride, 2 mins cool down.

Ride #1: Wattbike paired with the Zwift App on my iPhone 8 (not using Apple TV)
Result: ERG mode kicked in for the full ride with enough resistance to allow me to push it as hard as I could throughout the free ride section.

Ride #2: Wattbike paired with Apple TV via Bluetooth
Result: ERG mode kicked in for the warmup & cool down but I was left spinning out during the free ride section. I could switch ERG off & move the orange bar up/down but it made no difference to the resistance on my Wattbike.

Ride #3: Wattbike paired with Apple TV via the Companion app
Screenshot 2020-06-16 at 21.23.43
Result: ERG mode kicked in for the full ride with enough resistance to allow me to push it as hard as I could throughout.

Conclusion: Ride #2, the connection via Bluetooth is the problem.

@Gerrie_Delport - can you please confirm that all three scenarios above should definitely allow me to use my Wattbike correctly with Zwift? Can you also confirm that this will now be passed to your dev team for a fix ASAP?

1 Like

Hi @Dave_Dorward

That’s some good testing. I’m not on Zwift staff only a moderator and passionate zwifter on this forum.

@shooj can you flag this up. Thanks.

1 Like

My bad @Gerrie_Delport - I just assumed you were a Zwifty.
Apologies for directing my frustrations towards you.
Thanks for your help so far & for tagging in @shooj.
Regards, Dave.

1 Like

They should all work the same.

How far is your AppleTV from the Wattbike? Regardless, odd that ERG worked for warm-up and cool down but not the main workout block(s). Sounds like a Zwift bug related to the Wattbike.

While the forums are a great place to get some quick help or discuss things, your best bet would be to open a support ticket with Zwift via support@zwift.com

1 Like

All - issues with resistance on a Wattbike have long frustrated our members, and also our QA team. We’ve tried wrestling with it from many different approaches.

Would all of you on this thread chime in if you’re not on Apple TV’s native Bluetooth connection? There is a ticket opened for this narrow focus.

  1. Is anyone NOT using TVOS (that is, some flavor of Apple TV)?

  2. Is anyone using an ANT+ intermediary bridge like Zwift Companion, or North Pole Engineering’s CABLE device?

[zbri-405]

1 Like

Hi. I use an android tablet (Samsung) and an android 'phone (SAmsung S8) and I get this too. Quite honestly this is a biggie for me and I won’t be subscribing if they can’t sort this out.

1 Like

18 months this ‘glitch’ has been present. I have the problem that the watts remain at the same level as the previous interval when moving to free ride. As these intervals are often meant to be rest segmentS the workout is compromised.

As many of the workout sessions have free ride portions it’s a huge problem IMO. Zwift really need to fix the problem or state that Zwift Certification for the Atom doesn’t extend to use through Apple TV. I agree with those above, it’s simply not good enough.

1 Like

I have the same issue, using atom and Samsung tab S4. 12 weeks of build up, into the crucial 20 mins and this! Infuriating, I’m cancelling my subscription until this is sorted.