Cadence stops pairing

I wrote this as a reply to a previous topic last week. Have not had a response.

‘I was about to post the exact same problem. Three updates ago, the cadence sensor would not pick up. My solution is to delete and reload zwift. It lasts 2-3 days and I have to do it again. I have tried to contact support about the issue and all I get is that it is interference somewhere. I have been on zwift since 2019 and have the exact same set up. I have never had the problem prior to earlier this year. PLEASE consider this a bug that needs to be addressed. It really screws up my morning when I have to wait 15 minutes for everything to reload. I also use Apple TV but have also seen similar complaints on Android posted here.’

With the latest update, I am having to delete and reload the app on a daily basis just to get the cadence to appear. This issue is incredibly aggravating. As I mentioned, I contacted tech support when this first started happened over a month ago. One of the suggestions was to ride without cadence. That would be fine but Zwift won’t let me (plus I really need the cadence for several of the workouts). If I load a ride without the cadence activated, my avatar just sits there. The fact that I can delete and reload the app, and the cadence magically appears, suggests to me that this is not an interference issue but a bug in the system.

I don’t need instant solutions. My current solution delays my work out by 15 minutes and is painful but works. I need you to tell you to tell me that you are working on debugging the system. This happened as a result of the recent updates, not because my set up is the problem.


Hi @Micheal_Kuhn

Shuji at Zwift HQ here. Which version of the Wahoo KICKR do you have? I looked in your server logs and your trainer is on firmware version 3.4.70, so I’m guessing it’s the KICKR v4 (2018), please verify?

Please update your trainer to Wahoo’s latest firmware v 3.5.2. Instructions to do so are on Wahoo’s support site. Most notably, they added support for the Bluetooth FTMS sub-protocol in v3.5.1, and that is important.

Please let us know if that resolves your sensor pairing issue?

Thanks so much for a rapid and reasonable response. I will check and update.


So I updated. It worked for one day. Since then I have had to delete and reload the app to get cadence to work.