Cadence Sensors not pairing since update

Hi all
Just a heads up.
I’ve seen lots of complaints about sensors not working since last update.
Just to let u know, every three or four updates, I have suffered some glitch or other, which at best us frustrating, at worst not working components.
But on these occasions I uninstall zwift in it’s entirety, and re download,and it seems to rectify it.
I know, we shouldn’t have yo do this, snd on other training platforms not necessary, but it seems yo work ft or me.
Just saying…

Oddly, The cadence sensor pairs fine if I use my phone or ipad but when I go through my apple tv, it does not. I have tried refreshing the app many times… Anyone else have issues with apple tv?

Hi @Marty_Natterer, welcome to Forums. It’s Juan here from Zwift. I appreciate you post your issue in this space. I understand how critical it is for you to enjoy Zwift in your Apple TV. A cadence sensor provides you with data for most Zwift workouts because it helps you identify where you are most efficient.

The Apple TV only has 3 Bluetooth channels. One of them takes the remote control. If you are using an smart trainer, it could take a more than one Bluetooth channel depending how you pair it.

If you haven’t tried it, I would like to suggest using the Zwift Companion app as a bridge. Please refer to this article for more information on this.

I hope this information has been useful. If you were looking for something different, I encourage you to contact us to provide us with more details. We will be happy to help you.

Thanks. Oddly it was working without issue the last few weeks. Ironically, I am struggling to pair the companion app too. If I just hookup my ipad both seem fine. Going through the Apple TV app seems to be giving me some grief. I’ll review your article.


Marty Natterer

I was about to post the exact same problem. Three updates ago, the cadence sensor would not pick up. My solution is to delete and reload zwift. It lasts 2-3 days and I have to do it again. I have tried to contact support about the issue and all I get is that it is interference somewhere. I have been on zwift since 2019 and have the exact same set up. I have never had the problem prior to earlier this year. PLEASE consider this a bug that needs to be addressed. It really screws up my morning when I have to wait 15 minutes for everything to reload. I also use Apple TV but have also seen similar complaints on Android posted here.


Hi @Donald_Gino_Howe_Vel, @Micheal_Kuhn and @Marty_Natterer, thank you for reaching out on our forums.

The pairing issue you’re experiencing on your Apple TV might be related to this issue:

Our developers are currently working on a fix for this in our next update, which is scheduled for early April.

I installed the recent update. I had the same problem this AM with zwift not picking up my cadence. I had to delete the app and reinstall. So as far as I can tell, the issue has not been fixed with the most recent update.



Any news? Am still having to delete and reload the app every single time.