Bug? No Alpe Power Ups

Rode the Alpe last night and pushed hard enough to get a PR! I noticed that there were zero power ups available in the normal 3 spots (with timers) and no timers either. Thought I read that Zwift fixed those with the last update (updated again this morning).
Thanks for all your work to make an awesome game awesomer.
Ron Chatfield

Sorry about that, I rode it on Sunday and from what I remember there were 2 power ups along the way that I got then the final power up at the peak. I assume you were riding it in SIM mode and not as part of a workout? Power ups are not available during workouts. Also what device are you using for Zwift (PC, Mac, iPhone, iPad, AppleTV)?

I use an iPad for Zwift and iPhone for Companion app. I wasn’t in a workout. I update the apps every morning and remember reading that the App Store description of updates was to fix the Alpe Powerups so I was excited to try and get some of them. The Wheel of Fortune still worked (I got gloves) but that isn’t the Powerup I was looking for. I was hoping for Feather, Feather, Feather! Lol, I know you understand.

Hmmm, no answers there. maybe it was a one off issue that day as on AppleTV (which should be the same program as the iPad version) I had 2 power ups on Sunday. Granted only got 1 feather then someone with a sick sense of humor gave me a draft boost as my 2nd one.

Had the same on Friday no Power ups on Alpe and Zwift did not give the Tour of Fire and Ice route badge. Also seeing powers not working in other parts of Watopia i.e. Start/Finish banner in Downtown Watopia and jungle circuit counter

I road the 1.5 weeks ago and didn’t get the power ups on the way up but did get the Road to Sky badge. Rode it again on Sunday and received the proper power ups. Both times on AppleTV.

I completed my 1st Alpe climb this past weekend using Road to Sky on PC (Win10). The only powerup I saw was at the top as I passed the banner and it did the “wheel-o-prizes” thing.

Are there supposed to be powerups along the way?

Last time I rode the Alpe (Feb 9), I noticed the same thing - no power ups at all. Also, there is still the bug where the it wasn’t displaying the PR time for any segment (I’d ridden it 4 previous times). At least the wheel spun when I reached the top - in my previous run it didn’t appear at all.

Apple TV as the device, up to date in Zwift version at the time.

As someone else mentioned, A bunch of the start/finish banners are no longer giving power ups in the ATV version. I noticed Watopia, and Yorkshire were not working.

Man, get some software QC Zwift instead of rolling around in that $120 million you raised!

I had ridden two more Watopia routes tonight and been through the start finish banner 4 times, there were no power ups on an of these 4 occurrences.

Ah the well documented ZWIFT app. When do the alpe power ups show, and when do the timers show. Crickets…