Bowflex treadmill pairs to Windows & Android, but no runspeed [August 2023]

Got a bowflex 326 which was working a while back, just got onto the setup again after some time off (wife gave birth) and now my avatar doesnt move and the speed isnt registering.

Latest update on Zwift running on windows PC.
Kicker ticker and headwind working like a dream, just the treadmill.
Pairs OK and shows 0kmh in pairing.
Start the Zwift app and speed stays on 0 when treadmil is running so avatar is stationary…

Tried unpairing and re-pairing. Rebooted all devices numerous times. Reset bluetooth on PC.

Bowflex works fine paired to jrny app with all stats coming through…

Any help gratefully received.

Known issue with Bowflex treadmills and Zwift not working. I’ve had the same issue on my BTX226. Been going back and forth with @Rowdy help but nothing has worked so far. Weird thing is the treadmill works fine on the AppleTV app so it’s something specific to the code for the PC version.

Hi @70sCookie , I’m glad to help investigate this issue. Having a larger group of reports will help us get to a fix much faster. Are you running the Jrny app on the same PC as you use for Zwift?

Edit: I’m assuming this is the same known issue that @D_Watson is experiencing, so I updated the title of this thread in order to help any other Bowflex/PC Zwifters find it. If you aren’t able to see runspeed in Zwift on any device (including your phone or an Apple TV), this may be a new issue.

Hey @Rowdy

Thanks for coming back so quickly…
So the jrny app is on my android phone.
Connects without a problem.

Forgot to mention i also tried to connect the Bowflex to the Zwift app (fresh download today) on the same phone but same result. Sees it and pairs at 0kmh with no avatar movement.

Hi @Rowdy,

Any ideas on anything you want me to try?
Happy to do any reg hacks if needed, been a sys admin for a lifetime…


Hey @Rowdy

Any movement?


@Rowdy just installed zwift on my surface pro too and tested… same thing. :pensive:

Hi @70sCookie , I’ve grabbed your most recent 1.45.0 logs from the server and added them to the developer ticket for this issue. I’m afraid I still don’t have an estimated fix date, but there is movement on the issue.

Hi @Rowdy
Did the last update and tried again, still same if you need to grab more log files.


Thank you @70sCookie ! I’ll grab those log files from the back end and add them to the developer ticket.

@Rowdy @D_Watson
So a bit of a break through on Tuesday.
It may be a red herring but…
The jrny app mentioned to turn the vilume right down on the treadmill when i was playing around again after another update i believe.
And the jrny app connected and disconnected because i hadnt turned the volume down (didnt think it was necessary).
So did as i was told and jrny connected and controlled the treadmill. All OK.

Tried Zwift on the PC again direct connect and it doesnt even see the trainer any more…


Tried linking it through the companion app and it picked up straight away and actually worked!!!

Reset everything and tried again with volume back up on the treadmill and no joy…

Reset everything again and tryed with volume down on zwift direct. No joy…

Reset everything and tried again with treadmill volume down and pairing through phone(via companion app) and voila… worked…

Havent tried it again since but thought the log files may prove usefull…


Thank you @70sCookie , I’ve added these notes and your logs to the ticket. I just want to confirm that I highlight this correctly- the phone that you’re using for Zwift Companion is the same phone that didn’t show runspeed when you paired the treadmill directly to Zwift running on that phone?

Thats correct. Its a galalxy fold 4 for ref…

Would be good to know if @D_Watson has the same experience.

@70sCookie when loading the Jrny app on iOS there is no “run with Zwift” option I can find. So doesn’t work for me

Hi @D_Watson,
Sorry my post was a bit misleading.
I just used the jrny app to test the connection.
I dont use it with Zwift at all.

It was just the jrny app told me to turn the volume on the treadmill right down and it kept crashing when i didnt…

Thats what propted me to turn the volume right down for Zwift and it worked when i paired the treadmill via the zwift companion (select pair using phone in the top left of the pc app when pairing treadmill).

Hope that makes sense, and good luck.