Bowflex C7 connects, but no power output/movement [November 2023]

Bowflex was giving me crap like I did something wrong ? lol. Terrible service. It’s not Zwift at all….


Came across this post after trying to troubleshoot w/no luck. Behavior definitely started after latest JRNY update last week. Bowflex support is aware of the issue and their tech engineers are looking into addressing issue. No timeline given. Support requested that I open a a case via JRNY app to provide more info and to stay informed on the issue. (Launch JRNY app->click on profile->Feedback & Support). Hoping they resolve this soon.


They said no timeline to me as well…. I told them to reinstall the prior update lol. They said no. Now it’s a waiting game on there end….

1 Like

I’m having the same issue and it seems to have started this week for me. Bowflex C7/JRNY and have been using Zwift for about a year without issues. This past week Zwift is showing connection error when I load a ride. However, at the opening screens (as the “Let’s Go” button loads), Zwift is showing that power (through Bowflex), cadence (Wahoo Cadence sensor or Bowflex?), and heart rate (monitor that came with Bowflex) monitors are all paired. But, once the ride starts a blue box in the upper left of the Zwift screen says connection error (but still reads heart rate/BPM)

1 Like

Thanks Oscar. I’ll submit an issue to JRNY as well.

1 Like

The JRNY app has been a real disappointment. Worst part of the Bowflex C7 is dealing with the JRNY app. I’ve been frustrated that the app automatically closes a ride at 100 minutes.

1 Like

Exactly !!! When I do a 200km ride it says your done every 60 km or so. Terrible

1 Like

I thought I was doing something wrong! I haven’t ridden in a few days and hoped on today for academy #3 and got nothing. Been running around like an ■■■■■■■ trying to figure it out, at least I’m not the only one. Calling support now.

1 Like

I have the same problem. I’m able to connect my C7 to the iOS app on my iPhone but when I go into the ride, the avatar won’t move.
I have reinstalled Zwift but the issue stills there.
I will be grateful if anyone knows a solution.

Since last week, I have started experiencing this same issue with the bluetooth connection from my Bowflex C7 and Zwift.

I have tested on a windows laptop (my usual zwift device), android phone and tablet and also my wife’s iphone.

When I start the Zwift workout on the bike and launch Zwift, it pairs without issue to the bike and my HRM… but after 10-15 seconds, it shows ‘No Signal’ on the bikes connections. The HRM connection continues to work and display heart rate.

I also tested the bluetooth connection with the Bike and QZ App on my android phone.
It exhibits the same issue. It detects, connects but does not seem to be sending any data to the app over bluetooth.

I just talked to someone, they know and are working on it. How long it will take because of thanksgiving, who knows. Just for reference, my tablet version is if that changes I’ll post again.

Same issue for me. Began last Thursday. It’s been a week since I was forced to do the update on my Bowflex VeloCore and still can’t Zwift. Super frustrating as I’m paying for Zwift in the meantime and was enrolled in a couple rides I was looking forward to competing in.

Bowflex ticket opened. I’d give anything for them to go back to the previous working version. I was happy until this.

1 Like

Ok. This sucks. Got on my Velocore early for a Thanksgiving Day ride so I could offset a few of the thousands of calories I’m going to consume today and… my avatar no pedal!!!

Spent 30mins connecting/disconnecting, downloading… etc. nada!

Thank goodness this thread is here (wish I would have found it before a kicked the bike and spiked my iPad :crazy_face:)

Is there a number to call for JRNY? I redownloaded the JRNY on my iPhone but couldn’t find a way to open a ticket. (btw my JRNY app can’t find my bike either).

In the meantime, what the hell am I supposed to do?!? Go ride in the real world?!? Yuck.

1 Like

Same issue here on all platforms: Windows, Android and Ipad/Iphone. I’ve just emailed nautilus support in the UK to see what they say…

@here - To contact JRNY to open a ticket and add your voice to this issue (and get eMail updates on any solution), use this eMail address:

1 Like

Patiently waiting still no update yet

I’m having the same bowflex issues as well. My hub works fine.

I also have a bowflex treadmill that does the same. A workaround for running is to connect speed/ cadence to a HRM (If you’re into that sorta thing).

I’m still waiting too. Haven’t heard anything. I did have an automated email response from JRNY last week:
"Automation for Jira commented:


We are currently aware of an issue related to your request and are working hard to get this fixed!

We have linked your ticket with the known issue (Peloton & Zwift Don’t Remain Connected To JRNY Touchscreen Product) and will keep you updated with our progress. We apologize for the inconvenience!

JRNY Support"

2 weeks since last post but doesn’t look like this was closed out. I’m having this issue with Zwift on a C7 I just got.
Connects to my devices (Android phone - S23 and an old iPad) but no movement, just “:connection failure” in the top right.

1 Like

Tried again just now… no luck. The bike name on the connection pairing screen changed last week… used to say “ Nautilus” now says “C9/C10-AEF”. Progress maybe??

I attempted to add something to my ticket by leaving a comment with them on the JRNY feedback link they sent me… ugh.