Bowflex BXT Treadmill Bluetooth "Connection Error" [December 2022]

Hello. I commented on a previous post regarding the Bowflex connection issues, but I see it was marked as solved and nothing there helped me get my connections back. I am able to find and connect to my treadmill instantly, but then have “connection error” when I go to start, so the avatar never moves. I thought the issue was an older laptop that I had been using the last couple years, so I even bought a brand new PC, fresh install of Zwift, reset the treadmill, and still no luck. That’s when I found this forum. Current Zwift version is 1.31.1 on PC.

I also tried on my Samsung S20+ just to see if it was PC only, but I get the exact same error.

Thank you!

It’s an ongoing issue with regards to the pairing failing after a certain date.

@manda_F can you sort this please for the OP?

1 Like

Thanks for the reply and tag @10K.Every.Day.In.23. I saw some of the previous threads, and that the solutions seemed to be some backend magic. I’m hoping the same magic will work for me. I didn’t want to create a new thread, but the other ones were marked solved, and none of the actions within those worked for me. So here I am. :slight_smile:

Thanks again! :crossed_fingers:

You did right. There’s a long term fix coming but until then one of our friendly Zwift staff members will do their magic.

@Rowdy is also a good source for these things. :wink:

1 Like


When “connection error” appears in the blue bike/run computer in the upper left corner of the Zwift screen, it’s usually due to pairing being lost or no information coming from a paired device, which can be caused by many different variables. This is different from an issue we had with some Treadmills temporarily becoming “invisible” to Zwift.

@Michael_Corneau I can work with you directly to help out with your situation.


I am having the same issue with my BXT 216 and Windows 11. Your assistance would be greatly appreciated.

Hello all,

Our devs are now investigating this issue. A possible method that should help avoid this connection error is to launch Zwift with your treadmill fully powered off, make sure no other devices attempt to pair to Zwift, then power on the treadmill at the initial pairing screen.

I would add iOS as well. Up until about a month ago I was able to sync my Bowflex T22 to a Apple TV4k. Within the past week or so it detected, then disappeared. From that point forward, the app doesn’t see the device. I will try the suggestion that @Rowdy provided this AM as a workaround.

Update: I have confirmed the workaround provided worked correctly. However, I also connected a BT HRM which initially connected, activity started - then device disconnected. If I tried to reconnect it would show the treadmill as the HRM.

Hi @Rowdy could you drop me a DM also please. Having similar issues with our Bowflex BXT326.
Connection established but avatar not moving and then a connection error message appears.
Many thanks

Hello @Max_Naughton , I’ve moved your comment over into this thread matching your issue and reached out to you directly in a support ticket.

Did it work out for you guys? Im having the exsact same problem. If i try many times it suddenly start working. But for the third time now its been stopping halfway trough my workout. Was not happy when it stopped 5k into my 10k run🥺

Hi there! I am having this exact same issue, except it is with my Bowflex Velocore bike and my Samsung Galaxy S8+ tablet. My tablet/Zwift have always been able to connect and work with my bike over Bluetooth, but for some reason since the latest update, Zwift no longer can find my bike on the search screen. However, Zwift works completely fine with no issues on my iPhone with the bike and my iPhone finds the bike right away. Has a solution to this problem been discovered yet? I am assuming it has something to do with the android version of the app. While I can still cycle by using the Zwift app on my iPhone, it isn’t very convenient for me due to the small screen size on my phone. Many thanks.

1 Like

yes i also, my trainer Yesoul S3 can’t connect with android apps in Samsung S21 Ultra and Samsung S6 Tab.But in ipad and iphone can connect.
Any Solution?

1 Like

Any update on this issue? I have similar problem here. AppleTV4K, Bowflex116. Have tried both using AppleTV native bluetooth and Companion App (iphone13). All apps and devices are patched up to most current version. On Zwift initial pairing page, Swift locates, identifies and connects to the Bowflex. However, runner never starts moving, and within about 10 seconds getting “Connection Error” in top left.
Super frustrating.

Unfortunately no resolution here. I just tried again with a fresh install of Zwift, after running outdoors in the snow for the last couple months. On the upside, warmer weather is coming soon. :person_shrugging:

I’m not sure of I should comment here for an ongoing issue, or start new. I’ll comment here so that the history is known and if no reply, I’ll create a new ticket. I’m still having this connection issue error. Now that the weather is cooling, I would love to get running indoors again, but this has been an issue for nearly a year now. :pensive:

As when I first posted this problem, I have tried from a point of everything powered down so that I know nothing else is stealing the connection. I have tried on the old laptop that had worked for a few years, a new PC bought specially for Zwift, and even my Samsung S20. All devices are able to get the initial connection with the Bowflex treadmill, and confirmed with the blue light on the Bowflex. But after a few seconds, I then get the connection error making Zwift unusable.

Is there still a fix in the works, or has Bowflex been abandoned? Are there other apps that work with Bluetooth treadmills?


Michael, possibly a stupid question but 10 or so posts up there is a message from Rowdy that he could work directly with you. Did this not get you anywhere?

Unfortunately not. Had tried various things to troubleshoot, but ultimately nothing resolved the issue. So I figured I would give it the summer and hope that a fix was found. I just tried setting up again, updated my Zwift client, and still no luck.

Thanks for checking Ian.

Not sure if you have been able to find and read recent Bowflex threads but there might be some possibly helpful 3rd party solutions outside of Zwift.

@10K.Every.Day.In.23 may be along shortly and point you in the right direction.

What model of Bowflex do you have?

Otherwise I can’t directly help.

1 Like

Thanks @Ian_Attoe,

I’ll look back through the history I’ve got around this issue.

Michael, please confirm the model no of your Bowflex and the firmware version you are currently running and I’ll look into it.