Bluetooth not picking up anything

Downloaded Zwift android today on a samsung A5. Tried to Zwift run this evening using a milestone pod… Unfortunately Zwift can’t find the pod… (yes bluetooth is on)… it tried to fix by pairing pod in the android bluetooth menu (knowing your not supposed to do that but wanted to make sur pod was visible (and it was)), rebooted the app, rebooted the phone all together, turned off wifi to avoid interference… nothing worked… Zwift will not see the pod… lost motivation for my run :neutral_face:

Just getting started on Zwift Android so sorry for resurrecting an old thread. I sent a customer support request in yesterday for the exact same issue using a Milestone Pod on the Pixel 2XL, Zwift with Zwift build v26 1.0.31443. Hoping someone has some updates on a resolution here…

Uninstalled and reinstalled the Zwift app and now it seems to be working correctly. Milestone footpod and Wahoo bluetooth heart rate strap were both found right away. Seems like all has been resolved.

Hi, i have the same issue. Bought a milestone footpod, install zwift for Android but Zwift doesn’t find my footpod.
The pod is vissible in the bluetooth device list on my phone but when i will connect with zwift, zwift doesn’t find the pod.
Reinstall zwift, same problem.
I dowloaded the milestone app, this works well, this app sees my footpod !
Zwift doesn’t :disappointed_relieved:.
Is their an other solution ???

Hi, Same here with my p20pro and my Milestone Pod. Please fix this. Thanks!

does not find sensors, android 8.1 xiaomi A2 :frowning_face:

had enough with my milestone pod,change the battery already ,works 3 km then stop! now the milestone pod is inside my rubbish bin :sweat_smile::+1:

Same issue on the Google Pixel XL. Doesn’t show it.
But when I use my iPad, it detects immediately the milestone pod. So I would guess the issue is with Zwift Android and not the pod itself.

I’ll try maybe uninstalling the Milestone App in case it conflicts?

I am using a Lenovo Pro Tab 3 and I too have great difficulty pairing bluetooth sensors. I have a Stages powermeter and a Wahoo Tickr. I have found that if I open bluetooth settings my device first after ‘waking’ all devices, I verify the bluetooth on my device sees the devices. I then launch Zwift and go through the Pairing process. Even with these steps I have found it can take anywhere from a few minutes to over 10 minutes before Zwift ‘sees’ the devices. Most often it is closer to 10+ minutes. If you leave it on Searching and continue spinning it should eventually find them. On my Windows PC it always remembers the pairing and connects immediately.

Has anyone got a fix for this aside from waiting 10+ minutes?
I am running a samsung galaxy note 9 with the latest software and latest version of Zwift. I am still struggling to get my foot pod to pair with my phone.