Bluetooth devices connect, but No Signal [January 2022] [Windows11]

last inf from suppport :
We appreciate you undertaking the steps provided, and we’re understand your frustration with this persisting issue.

After investigating this further on our system, this appears to be a new bug, and our dev team is working to resolve these problems with the Windows 11 Bluetooth connection. Feel free to check out our forums ​for further updates on the matter, and look out for game updates–as they will likely offer a patch for the issue.

In the mean time, we recommend that you use an ANT+ dongle to connect using the Zwift Companion app bridge​, or downgrade back to Windows 10 for the time being.

Don’t hesitate to let us know if you have any further questions or concerns about this.

We appreciate your cotinued understanding and cooperation on this matter.

:crazy_face: :crazy_face: :crazy_face:

I`m try to connect by ANT+ dongle to PC and everything was fine fo 90 min training.

1 Like

Zwift support just told me they’re working on a fix, and a future update will hopefully resolve this. So really not much we can do now but wait.

Edit: You can ignore the following part of my original comment, as Thomas has experienced differently than me…

Original

If anyone is considering downgrading to Windows 10, I would guess that it’s not worth the trouble, and won’t fix the problem. The bluetooth connection problem started in September with Zwift’s 1.17 update, and everyone was using Windows 10.

I respectfully disagree. I had the latest updates in Windows 10, updated to Windows 11 and could not keep Bluetooth connected. It would show connected right at the start and then drop. I downgraded to Windows 10 and everything works fine. I don’t have an Ant+ dongle and have to stay at Windows 10 until this is fixed.

3 Likes

Same issue here as well with my new Windows 11 laptop. Connects when pairing up but as soon as it switches screens to start the ride it says connection error and nothing

Same issue here, Zwift Ambassadors o ly response is ‘ANT+ is an option’. This isnt really good enough. Haven’t been able to use Zwift for a week.

Hi @Gaz_Stevens_Kernow

What system do you use. Can you explain the issue?

1 Like

Not sure if this is the cause for Windows11 but I turned off mt bluetooth on my cell phone and now it has worked flawlessly twice in a row. Fingers crossed!! Not sure if the bluetooth on my iphone was causing some kind of interference with Zwift on Windows11 or not?

Hi, I experience those Connection failure also but only randomly during workouts and not directly on entering the game (yesterday last). Since most of the posts refer to Win 11 I can confirm that the connection issue also occurs on Windows 10 PC which never has been upgraded to Win 11 before.
Paring screen shows devices still connected but Power Source and Controllable saying “no signal”.
Somtimes I can continue riding after shortly disconnecting trainer from power supply and unpairing/paring devices again. Worst case I need to restart PC and trainer and unpair/pair devices again which is no fun since workout progress is lost.

• Tacx Flux 2 Smart Trainer 2021
• Garmin Cadence Sensor
• Dell Latitude E5440; i5-4300; 4GB RAM
• Windows 10 21H2
• USB TP-Link BT 5.0 (build-in Intel BT device disabled in device manager)
• Companion App (3.31.0) on iPhone 6s Plus; iOS 15.1
• Zwift Game Version: 1.0.100278

1 Like

I can confirm this is also an issue in Windows 10.
Struggeling to get connection, connection lost during riding.

This is a very frustrating issue that ruins my zwift experience.

1 Like

Sorry to abandon all hope…I bit the bullet and purchased an ANT+ USB dongle - works flawlessly.

BT still completely busted but at least I can ride/train on 2 devices, or even just ride around in zwift now.

Still piss poor I had to do that, but here we are.

Same issue on windows 10. Frequent dropouts since a couple of months: with both bluetooth and ANT+ . With Golden Cheetah (freeware) ( only ANT+) there are no problems.

So Zwift: get this thing fixed in two weeks or I leave.

Hi @CB2

Do you have have the ant+ dongle on a good extension cable close to the trainer. Did you look at your log files in Zwiftalizer.

With a good dongle and no outside interference you should not get dropouts with ANT+

The dongle works fine with another program, so Zwift is disfunctioning for a couple of months.
Following just now the suggestion in this thread of deleting two xml files: that seems to work: good swift connections.
Checked after exiting Zwift and did not see any new versions of those files. Are they obsolete? If that is true, then please let this happening automatic with the next update!

Connections okay, but dropouts two in 15 seconds! I give up and end my subscription now, as everyone should do with this kind of troubles.

This is not normal.

I had posted earlier about Windows 11 issues and had rolled back to Win 10 and things worked fine. Well, Windows forced another update to Windows 11, I rolled back again, and NOW, Windows 10 shows the same issue - connected, but no signal. I can connect fine using Zwift Companion on my android phone, so I will probably just update to Win 11 and be done with that issue - assuming Zwift Companion will still work. I will try the approach of deleting the XML files referenced and post if that solves both or either the Win 10 and Win 11 issues.

I just got a Wahoo Kickr, signed up for Zwift (first time user), and am having this exact same issue on Windows 11. Zwift pairs with the Kickr, then presents “Connection Failure” message usually before I start pedaling. Using the Zwift app on my iPhone works well, so it isn’t a problem with the Kickr. I tried all the fixes above, but had no luck.

Same issue. Really disturbing. Using ANT+ as temporary solution, but prefer BLE.

1 Like

Same problem here since the update to Windows 11. Zwift does connect with my Tacx with Bluetooth, but after one or two seconds, it says “no signal”. Very frustrating. I installed the new zwift update this morning but it still doesn’t work… I hope Zwift will come with a solution soon.

Was hoping the new release yesterday would fix the problem, but it does not. Is @Lauren still following this issue?