Bluetooth devices connect, but No Signal [January 2022] [Windows11]

Windows 11 fully updated, seconds after pairing the message “No signal” pops-up. I updated my computer yesterday after my Zwift ride without any problems… stupid me ;-)!

Zwifting on a iPhone ain’t pretty, please fix it fast :slight_smile:.

1 Like

Same problem. Win 11
I can see my cadance but not my power.
I now connect my trainer to my pc through the companion app. Not great for doing training; the lack is big.

1 Like

Me too - Running Zwift (1.19.2) on ATV & ZCA (3.30.0) on iPad Air since Nov update bluetooth devices connect then display no signal. So frustrating!

This is driving me mad now. Considering cancelling as no news, no eta on when this will work. Bkool is the same. No Bluetooth and Win11 support. :sob:

Hi all

As a work around you could use a usb ant+ dongle. I’ve been using one since updating to windows 11. I have the odd drop out on the heart rate strap but the trainer works perfectly.

1 Like

Thanks. I don’t have one so would need to buy one. I have paused my subscription for now and hopefully it will be fixed soon. I contacted support but they didn’t have an eta.

some updates her @Sarah_Stephens ?

1 Like

Also noticed bluetooth not working after Win 11 upgrade… Devices are visible, show full bars, will connect to Zwift… but then “no connection” immediately pops up on the device. Current work around is ANT+ dongle but it has fairly regular drops that ruin the ride immersion. Looking forward to a fix for this.

2 Likes

Laptop lenovo x1 nano with windows 11.

Garmin RS200 - powermeter and cadence
Garmin HRM-PRO - heartrate.

Bluetooth connection HRM is availiable in zwift, but no pulse after the start riding. I’m immediately get notification “connection problem”. Pulse works only with ant+ dongle, but every ride it often loses connection during the training.

Pedals work mostly stable on bluetooth connection, but I had a couple of workout with intermittent connection loss for few second.

WIth zwift on my iphone 13 mini HRM and pedals works on bluetooth with no problem: fast connection, smooth data reading,

I found that I am actually able to pair my trainer successfully using Bluetooth in Windows 11, but it takes several attempts for it to actually work. I recorded a screen capture with video overlay of my trainer’s Bluetooth light in the bottom right corner. As you can see it takes nearly 3 minutes of trying over and over again until my trainer light stays on solid after pairing:

youtu.be/-JdExpYHU3E

Sorry, this forum won’t let me link directly - you will have to copy/paste the above URL.

Strange behaviors to note:

  • Sometimes the trainer shows up twice (“Wahoo KICKR 9E” and “Wahoo KICKR 9E00 62” in my case)
  • Sometimes after I select the trainer for “power”, sometimes “controllable” and “cadence” are automatically selected with the same device, but usually not
  • Usually after choosing my trainer for “controllable”, “cadence” is automatically chosen as well, but sometimes not
  • In this video, it successfully paired using “Wahoo KICKR 9E00 62” for power, and “Wahoo KICKR 9E” for controllable/cadence, but that is a fluke. I’ve had it successfully pair with “Wahoo KICKR 9E00 62” selected for all in other attempts.
  • It usually takes between 3-10 pairing attempts for the pairing to succeed without dropping after closing the pairing screen.

This video was recorded w/ latest Game Version 1.0.100241

1 Like

While the steps in my video above do work - and I’m able to Zwift with full Bluetooth (power, controllable, cadence, HRM), I started experiencing other problems.

  • My HRM started dropping repeatedly (it does not drop at all when trainer is on ANT+)
  • Zwift crashed twice within 10 minutes

After wasting 30 minutes with the above issues, I switched back to ANT+ and managed to get an hour session in without crashes.

At this point, although it is possible to get the trainer working w/ Bluetooth in Windows 11, it’s clearly not worth the hassle in my opinion, at least until Zwift provides us with an update.

Here is answer from Zwift support for all our broblem.
Hi Sergio,

In one of your previous messages you mentioned that, you turned off other bluetooth devices that the trainer could potentially connect to. Aside of turning off other devices, it is also recommended to make sure that other trainer apps/third-party apps that can connect to your hardware are truned off as well.
Your trainer should not be paired directly in the Windows settings as well.

It might be also helpful to check for updates on the Windows side (e.g. bluetooth driver updates).

After you check for these things, please try to reset your Zwift game preferences along with the known devices list.

Here is what you’ll need to do:

  1. Close Zwift.
  2. On your desktop, open Documents .
  3. Double-click Zwift .
  4. Delete knowndevices.xml and prefs.xml .
  5. Launch Zwift.
  6. Pair your devices

If after following these steps you are still having trouble connecting your trainer to Zwift, I would like you to try using the Zwift Companion App again.
When you use Zwift on a computer—you can use the Zwift Companion (ZC) app on your mobile device to create a “bridge.”
With this bridge in place, ZC will convert your trainer’s BLE signal into a format that your computer can recognize.

Please bear in mind that in order for the bridge to work, you will need to enable location permissions on your android device.

More information about using the Zwift Companion App can be found here ​.

Please let us know how it goes. We are looking forward to hearing back from you!

Well, deleting the .xml files has worked for me. I can now enter a ride without my bluetooth devices dropping out.

Thanks for posting this! Before I re-update my laptop to windows 11, has anyone else had luck with this? I had rolled back to Windows 10 when the laptop wouldn’t connect. Thanks again

Deleting knowndevices.xml and prefs.xml allowed me to pair and ride without connection errors - once.

The next time I launched Zwift I had the same problem.

I closed Zwift, deleted the files again, re-paired devices, and still my trainer loses connection after closing the pairing screen.

This does not appear to be a reliable solution.

I have just tried connecting again after my previous success and I now get the connection failure message. Tried deleting the .xml flies again and still not working. Strange and very disappointing.

I just want to help all of us sending support answer.
You can write to support by yourself and maybe it helps when Swift team look for a lot of tickets.

@Lauren

are there news from official Zwift to this issue? Could you recreate the issue on your side? When can we expect to get a fix for it?

I do have the same issue using a surface pro 7 + update win 11

Just tried deleting the .xml preference files - bluetooth still not working. Devices register “no signal” after pairing.

Im having same No Signal error but after a few seconds will connect. Steering on my Kickr Bike doesn’t behave as expected though. The button that is meant to control steering to the right immediately puts me into a U turn. Anyone else having the problem?