Bluetooth broke with update [September 2021] [1.17.0] [Windows10] [SOLVED]

Hi Shuji @shooj

I have the exact same issue as Dave using the BT connection from Windows to my Kickr Core. The issue most definitely has not been solved!

Could you confirm that this is being looked at? I have the same issue in trying to deal with support - the Zwift Ambassador BillyC has been very helpful, but all support have done is send a standard link to FAQs about connecting equipment which was not relevant to the issue. And like Dave I have no way of taking it further as you can’t reply to the standard email.

I know it is a Zwift issue as all works fine with RGT,and it worked fine on and before 14th September before the update.

Would prefer to keep going with Zwift instead of RGT if possible, but can’t until this is fixed.

Anything you can do would be much appreciated - I’ve got a week before my membership pause starts: I can’t keep paying if it doesn’t work for me!

@Dave_Konicek
Sorry for the “no reply” bounceback email, that sounds like something went wrong in our email routing? I’ve let the right person on our team know about it.

In the meantime, I see that Steven has taken over for the more in depth troubleshooting. Did you get the email he sent earlier today (Monday)?

Hi @Alex_Bennett1
Our Ambassadors can escalate your ticket to an HQ tech specialist, who can take a more detailed look into your situation.

I looked into our support queue, and one of our HQ specialists (Sam) sent you an email 2 days ago asking you to check the firmware version on your trainer, etc. Did you not receive Sam’s email?

Thanks for the uber-quick response.

Just checked all folders, including Junk, and no, nothing from anyone other than BillyC.

I’ve DMd you my email just to check there wasn’t an error in the address

@shooj I received an email yesterday, but it was just the automated response message again saying “replies sent to this inbox will no longer directly reach our team” and no personalized message from Steven.

@Dave_Konicek

Sorry for that confusing message that should not have been sent - we’re looking into why it was. If you reply, it should route correctly back to right person. Would you give that a try?

@shooj just an update to say nothing received as yet from anyone since your reply to my DM yesterday. Not sure whether I should have done by now TBF :slight_smile:

You did say they wanted to know my firmware - it’s 1.1.1 as it has been for months, so that would have been the thing that changed

I tried today on the offchance - no change in resistance, although it did seem to connect better on loading, (but it obviously hadn’t actually done so)

@shooj in the words of Perry Farrell, I was standing in the shower, thinking*…

There’s another variable I hadn’t considered: as well as the zwift update, there was also a Windows Update between Zwift working for me and not.

Because all I’ve ever had to do with Zwift since I joined is switch on and everything has automatically connected via native BT, I’ve never had to look at any alternatives. So I didn’t know what Bridging BT via the CA was until doing further searching last night.

That has made me realise that effectively RGT uses it’s mobile app to bridge BT, so the fact that RGT works isn’t necessarily a direct comparison.

So I think the only thing I know for sure re: Zwift is that my Kickr Core works fine, but maybe the issue could be either the Zwift update or possibly something in the Windows update?

Now I know what bridging is and how to do it, I’ll test tonight when back from work and see whether that makes a difference.

  • after realising how RGT worked, the song and I diverged and didn’t end the same way :wink:

@shooj using the Zwift CA to bridge BT worked - resistance changed as expected for the 30 seconds or so riding I did (it’s a nice evening, I’m riding outside in a mo!)

So the issue is the direct BT connection between Windows App and the Kickr Core, caused either by the Zwift update or the Windows update.

I can’t see a way of working out which is the issue, but bridging the BT is a workaround.

The CA picked up the power and controllable, but not the cadence: I had to search separately on the Windows App to get that to work (which it did so no problems), but does that make sense?

1 Like

Same issue here. Windows 11 Pro - 22000.194

Wahoo Kickr 20

BT power / cadence shows as pairable, and intermittently shows power for 5 seconds maximum, then shows “No connection”

I tried both the vc_redist.x86.exe as well as dll file, and no improvements.

ANT+ working fine.

I have a similar issue but a bit different. I’m running Windows 10 with a Kickr Core, bluetooth connection. Everything used to work fine. But now although Zwift can pair with the Core and seems to be reading my cadence (and HR) correctly, I get virtually no change in resistance with gear changes or incline changes in the game. Just end up spinning at ridiculous cadence to get any kind of power. This appeared to be especially bad during a workout - free ride maybe a bit better but not sure. I tried playing around with Erg mode and other settings on the Options page but nothing worked. So basically I now can’t train, and there’s only a week left to finish the Academy rides…

This topic has to be marked as UNSOLVED.
Same problem as many described, worked before just fine with the same setup.
Windows 11, Tacx NEO 2T - Zwift connects to Tacx but in few seconds displays No connection. No resistance change on Tacx, power and cadence works with Garmin Vector 3.
Use mobile device and Zwift Companion as a workaround.