BLE Problems

I’ve been running Zwift for months with Elite Direto via BLE and never had an issue.
Yesterday after using my usual start up routine the app (android Galaxy S9) doesn’t detect my trainer.
I’ve tried re installing app. Restarting phone etc but it still wont pair.
Nothing else is paired and I’ve tried all I know.
Any help would be greatfully received.
The odd thing it works fine connecting using laptop and BLE.

Your phone won’t see it because your laptop has its attention. That’s how Bluetooth works.

Most BLE devices can only connect to one controller. Any chance that your laptop has usurped the connection?

My laptop wasn’t powered up whilst trying. I only used that option after being unable to connect phone.

Laptop only used after phone connection problems. No other devices with BLE connected at all its bizarre.

Has your phone had an update recently?

Not since last zwift use. I’ll see if I can do a manual one

I was thinking more along the lines of a recent phone update having affected its BT.

I’ll look into it . To be honest I’m baffled.

Does your phone pair with other BT devices ok? I.e. is the phone’s BT definitely still working?

Yes. Hoping it’s just a temp App glitch