BLE connection issue with Samsung Galaxy Tab S8

Dear all,

After hours searching for an answer to my bluetooth connection issue on Zwift, I try my luck sharing with you all! I know connection issues are common and problably have many causes, yet I wasn’t able to find someone experimenting my exact problem: if I missed it, I apologise.

Here’s my situation:

  • I’ve used Zwift in the past with an “old” Thinkpad computer working on Windows 10, using an ANT+ key paired with my Elite Turno home trainer (ant+ and BLE 4.0 compatible). It worked well and I’ve never experiment any drop outs or real lags during my races.

  • Sometimes, I’ve also used my phones (first an iPhone 7, then an iPhone XR) as well as my phone’s friend (an OnePlus 8T): all of them worked fine using BLE connection.

  • More recently, I’ve bought a Samsung Galaxy Tab S8 hoping to up my confort using Zwift. However, when I tried to use it, it appears the BLE signal wasn’t working properly. When looking to pair the home trainer, the BLE signal is detected, with 4 full green bars. Yet, when pedaling on the bike, signal is lost and there is never a steady data flow. I’ve only succeded to make the bike in the game moves for about 3 seconds before droping the signal again, in my ~10 trials.

To fix this issue, I’ve tried all the most common quick fixes you can find on the Internet, like the tips on Zwift FAQ on interference troubleshooting tips, as well as other fixes you can find on forums, websites, blogs, YouTube…

I’ve also tried more “in-depth” solutions, like installing ANT+ on the tablet to use my ANT+ key which was working fine on the computer. However, I’ve realised that the ANT+ apps on Android are not functionning correctly since Android 11, as the specific authorisations required to use it cannot be set anylonger.

Using Zwift Companion would have been a good fix too, but I cannot find the way to make it work. I know that on computer, you can select Zwift Companion to connect instead of the computer itself, but on the tablet, as well as on phones, I didn’t find how…

Finally, I’ve tried using other cycling apps to see if the problem came from Zwift itself. Surprisingly, on Kinomap, the Oneplus 8T phone does not work but the tablet partially does (let say I can connect 50% of the time versus 1% of the time on Zwift): this makes me think that the issue includes both the BLE home trainer itself AND the app I’m using.

If anyone has an idea on what to try or why it does not work, I’m ready to try everything :slight_smile:

Many thanks to anyone reading this and happy to try my luck here!

M.

I have the same problem with Galaxy Tab S7 and Jetblack Volt. The trainer connects via Bluetooth to Zwift App but I keep getting “No Signal” over each of the elements. I have tried reinstalling etc. but I cannot get the trainer and Zwift to ‘talk’. D

Hi, I’m having exactly the same issue with a Samsung Tab S8.

I’m using a tacx neo 2T, zwift drops the BLE connection

This is an issue with Zwift, not the trainer, I installed and connected with Tacx software to make sure my firmware was up to date, then I connected the trainer to the tacx app, went off and made lunch, came back an hour later and it was still connected, basically rock solid, unlike Zwift.

I never had any issues running Zwift on windows 10 on a surface pro, but work doesn’t like to see these apps installed on their equipment.

I uninstalled the tacx app, uninstalled Zwift, re installed zwift but the problem still exists. there is nothing on or trying to connect via bluetooth other then the app and the trainer.

i had read someone tried clearing bluetooth cache so I tried that also, didn’t help.

@ZwiftStaff1 - How do we get Zwift to look into this properly, i prefer zwift as a platform and don’t really want to have to change.

I was really happy when I bought my new tablet but a big part of why I bought it was for this…

Thanks,
Brendan

Hi @Brendan_Canning

Welcome to the forum.

Go to the Zwift permission settings on Android and clear it . Then when you open Zwift and it ask for permission set it to this time only.

I don’t have a samsung device so it may be slightly different but

go to settings, then apps, then zwift, under permissions make sure location permissions are allowed.

bluetooth permissions are under location on android.

Hi @Gerrie_Delport_ODZ and @Chris_Holton

Thanks for your replies, I have been doing everything I can think of but even with the location permissions on the issues persists.

The app does connect to the trainer and HR monitor but only for a short while, it might stay connected for about 25 mins or so and then drops, you have to come all of the way out to get it to reconnect.

I have even gone in and completely cleared out bluetooth cahe and data, effectively resetting bluetooth on the device, that was after uninstalling the app, then re-install the app, ensure all permissions are open etc but still the same issue.

I don’t know what other settings on the device could be impacting the app but I can’t figure it out. So I don’t know if it’s an issue with the device, the app, or the interaction of the two.

My solution is going to be to buy an apple cable and use my phone connected to a dell monitor I think. Just not the cleanest setup, the tablet would have been better.

Brendan.