BKOOL ant+ fe-c

Help! I’ve got a BKOOL Classic but I can’t get it to broadcast in ant+ fe-c and so no Zwift! I understand there is a way of converting using an earlier version of the BKOOL software. Can anyone help? Can anyone share this software? There are some links in this forum but they don’t work. Any other way of converting ant+? Does the NPE cable allow this to happen?

Hi Nicolas,

I have put the instructions for updating the Bkool Pro here: Bkool smartpro black - no connect zwift

I’m not sure if they work for the Bkool Classic, but I think the instructions in Spanish that I got mine from mention using a cable so it might be worth trying those: https://www.foromtb.com/threads/afectados-por-rodillo-bkool.1198660/page-80#post-27158993

Thanks Sandy. I’ve tried this but fail at the point where I edit the version data file. It won’t let me save the change. Any tips on how I can do that. I use notepad as the administrator but when I go to save it says I need BKOOL permission etc. BKOOL have been useless in all of this - and have advised that if I do change the protocol the trainer would stop working!
Many thanks,

Nicolas

Are you using a PC or Mac?

One option to try would be to create a new file, put “5.14” in it and call it “version.dat” when you save it. Then delete the old version.dat file and replace it with your new one. I had to do this when using a Mac.

Thanks Sandy. I’m using a pc. Will try this work around. One follow up question I had was a concern prompted by my emails to BKOOL which said if I tried to update the Classic by using old software this would ruin the trainer. Any thoughts? Also, I don’t need to connect the trainer to the PC using the usb cable do I? The process just makes the ant+ broadcast in fe-c?
Appreciate your help.

Nicolas

I don’t have a Bkool Classic so I can’t give any guarantees, but Spanish forum I linked to above were using a Classic with the cable to update to Ant+ FE-C and they didn’t report any problems that I can see (I don’t speak Spanish so haven’t read the whole thread, just translated post from
vicorente with the steps to update)

Once you have updated the Ant + FE-C then I don’t think you should need the cable for Zwift

Hi, I’m picking up a classic at the weekend. £50, so at the current inflated prices on certain re-sale websites, and no stock in shops, am happy.
But interested if Nicolas was successful

James

Hi James, let us know how you get on.

There’s a chance the previous owner may have done the work for you but if not then I think you should be able to get it working as a controllable trainer if you follow the steps to enable Ant+ FE-C

I have given it a go and had no luck. A forum member has given me a tip so will try that to see if it works! Otherwise I’m stuck with BKOOL software :sob:

Ok will do

No problems my end. Followed the Spanish instructions. All went Perfectly.
Error first time, but updated on the second attempt. First Zwift ride complete

Thanks for letting me know Jamie. Are you using pc or mac? And I can’t get past the updating the data file - I can’t save down as 5.14. How did you get round that?
Nic

I am using a PC, and a Bkool Classic with a mini usb Type b connection in the back.

I had no version of Zwift to start with. So downloaded the link included in the Spanish thread. I think it asked me to re-start PC. I didn’t.

Opened up notepad as an administrator. Then went to - C: \ Program Files (x86) \ Bkool Indoor \ BkoolIndoor_Data \ StreamingAssets

and opened up version.dat file.

Deleted the version number only and replaced it with 5.14

Saved the file over the existing one.

Connect the usb cable from the computer to the Bkool Classic, and Put the ANT+ connector in the PC.

Started Bkool

Connect and link the trainer.

Bkool told me a firmware version is available. - start Firmware update

The first time Bkool gave me an error. So I closed the Bkool Software (I think I did a PC restart as well, can’t be sure)
Then restarted Bkool and tried update firmware again and it worked.

Good luck

Hi all.

Have done all the above without any problems.

Just need to update the firmware, what size cable is it??? Just read comment above

Then i can get it up and running.

With changing the DAT file, right click on properties. Brings up a seperate box.
Tabs at top. Go to security.
Box underneath, select EDIT. Select USERS. Highlight it blue.
Box further down says FULL CONTROL Click on this and it will allow you to edit the file.

Go to the dat file and change the numbers. Done.

Sorted, thanks all. I just created a new dat file and deleted the one I couldn’t edit and moved the newly created one into the file. That got me up and running. Thanks for the advice.

1 Like

Something Like this https://images.app.goo.gl/GjvKXjUxWffeBDXG7