Can't connect to Bkool classic

Yesterday Zwift stopped connecting to Bkool classic trainer. We have tried to connect with two different pc and two different ant+ dongle without succes. I have used bkool and Swift about half year. Today I installed bkool simulator and this sw found the trainer easely. So can there be a situation on the Zwift sw?

Did you use the ANT+ FE-C protocol from Bkool? It’s on the Bkool website. It worked in my case, I use a Bkool smart trainer.



Zwift worked fine half a year. Yesterday it didn’t connect to trainer any more and I don’t know why. I installed Zwift to another pc without success.
Regards Tarmo

I had the same problem yesterday November 5th after having made an update of Zwift. Up to the update I haven’t had any problem to connect. I loaded on Appstore the App Bkool Toolkits, and it has updated directly my Bkool smart trainer. Now it works well and my home trainer can connect on Zwift.


Hi everyone,

I recently found a solution for those who own the Bkool Classic trainer (usb connector) and could not update to the latest firmware ( ANT+ FE-C) due to end of support. This way you can use Bkool Classic with Zwift.
It’s in Spanish, but you can use the translator.


Bkool Classic ANT+ FEC update

1 Like

I’ve followed the instructions, getting the old installer to launch, but not getting the button to update. Anyone had this problem and got a solution?
Starting to think about purging my Bkool with fire.

Hi @Ollie_Wykeham, are you connecting to the Bkool sim via Ant+ or Bluetooth? (or is it a cable on the classic?) On the Bkool Pro trainer I think you need to connect to the Bkool Sim via Ant+ to get the button to enable FEC