Better support for 2K Resolution 2560x1440

I recently upgraded my monitor to 2K and video card. I used the configuration hack to increase the resolution of Zwift to 2560x1440. The only downside is not everything is rendered at the highest resolution. I took a few snapshots. The rendering for my avatar is nice, but the other avatar are at a lower resolution.

At higher res, the bushes also appear to be floating in space :slight_smile:

Hi Peter, screen resolution and all the other graphics features have little or nothing to do with each other.  All we give you control of is screen resolution. There are at least half a dozen other graphics enhancements tied to different graphics hardware specs (one being the quality of 3d models used).

However, from the looks of it, we’re not properly recognizing you have a pretty nice graphics card.  I’ll see if I can sort that out for the next game update.  Thanks for bringing this to my attention. 

That would be great. I’m using this radeon card

4G RAM 256-Bit GDDR5

Radeon R7 370

1020 MHz

Could it be a video card driver related? I’ll check to see if I’m using the latest version.


I just updated to the latest AMD drivers 15.30.1025 and it still doesn’t recognize my video card. Hope that helps.

I just tried the last version and it’s all fixed! Thanks for turning that around so quickly. Looks soo much nicer now.

Peter, how do you increase your screen resolution for 2K display?

I think I have found it. Modified the first line of the ultra.txt config file to have the monitor resolution. FPS now seems pretty much locked in at 60FPS (which matches my monitor); and game looks awesome.

yup, if you stop peddling, when the pause screen show up, click on settings. it should be set on Ultra. Much nicer than the low res.

I had Ultra but this has a resolution of 1920x1080. I have modified the ultra.txt config file to the resolution of my screen; being 2560x1440. Seems to keep the FPS much more stable.

I assumed this is what you did for your screen.

yes, that is what I did. I modified the ultra.txt to this.


res 1920x1080(0x)
sres 2048x2048
aniso 4
set gSSAO=1
set gFXAA=1

Is that not the original? I gather the game will reset this on every update.

I have updated mine to match my screen resolution and it now looks like this:

res 2560x1440(0x)
sres 2048x2048
aniso 4
set gSSAO=1
set gFXAA=1

my original settings was from the beta, so it was different. the screen captures of zwift are 2560x1440 with my current settings.

Hi All.   You can simply edit the screen resolution from the settings button on the pause screen.  It has been in there for many months now and lets you pick between 720p, 1080p, 1440p or even 2160p (4k).

Any and all changes made to those config files may be wiped out at any time by Zwift due to various reasons.

thanks Jon. good to know that.

Are you saying that Ultra(1440p) matches my screen resolution of 2560x1440, even though the ultra.txt configuration file has the resolution defined as:

res 1920x1080(0x)

Which is actually only 1080p.

Looking in the configuration you have both high and medium defined as:

res 1280x720(0x)

Where high is defined as 1080p, but this being 720p.

Seems like you have High(1080p) defined as 720p and Ultra(1440) defined as 1080p.


Screen resolution and graphics settings are entirely separate from each other. You all are digging around in the folders and finding files named “ultra” or “high” and thus getting it confused with our publicly facing Game Resolution setting in the menus, which lets you dial in your resolution with similar names.  They are entirely unrelated things.  Some basic gpu users have set their resolution to High.  Some ULTRA users have set their resolution to Medium.  It’s a mix and match thing.

The resolution specified in the config files is simply what will be the default on that set of graphics chips, but you’re free to override at any time in the settings screen.