2K monitor support


I have a laptop that the screen is full HD but through a USB-C cable I connect a 2K monitor. Windows 10 correctly detects the resolution 2K on the second monitor, but in the Zwift configuration I have no option, I only get full hd and lower.

Best regards,

This isn’t a bug I’m afraid, it’s by design. As far as I’m aware, Zwift won’t allow you to select higher than 1080p on integrated graphics like your laptop as. You’re certainly restricted to the Basic profile, which means minimal shadows, environmental and lighting effects and detail. Neither restriction can be changed by the user.

To access the higher resolution settings (1440p and 2160p) and be shown the higher detail profiles (Medium, High or Ultra; you don’t get to choose) you need a dedicated graphics card.