4K / UHD tv set issues (PC, Windows 10)

Dear All,
I have PC with GTX1080 and Intel i7, 2 monitors (one Full HD 16:9 connected to DisplayPort output set as main screen and one older 16:10 WSGGA+ connected to DVI output) plus new Samsung UHD/4K TV set connected to HDMI output (resolution 3840 x 2160 @ 60 Hz in Windows settings). I use single extended desktop for all 3 screens and I work on 2 monitors or I play on TV screen. OS is Windows 10 64 bit Home. My trainer is Cycleops Hammer (connected via ANT+) which I have been sporadically using for couple of months.

I have been experiencing couple of issues with Zwift and described hardware setup.

First one was forcing Zwift to run always on TV set screen. Every time I was running Zwift, it was coming back to main monitor screen (despite the fact that last time it was forced to run on TV screen) and dragging and dropping Zwift’s window in order to move it back to TV screen was kind of nightmare because my TV set is on the opposite wall some 6 meters away from my PC and monitors (behind my back when I’m sitting in front of monitors) plus there is quite big difference in resolutions. Years ago there was very useful Windows XP add-on from Nvidia enabling to send any particular window to any particular screen by just couple of clicks but it is no longer available for current hardware / software setup. For some reason also playing with Win+P settings nor switching Zwift to windowed mode did not work for me. I even tried to move Zwift shortcut to TV screen before starting Zwift up but obviously it have never worked - no matter what I did Zwift was always or at least often displayed on my monitor instead of TV screen. The only fully successful solution I have found was disabling second monitor and switching main screen assignment from first monitor to TV screen before each Zwift session. Not very handy but at least it works. However, I was wondering whether there is some kind of Zwift or Windows setting to force Zwift to be displayed always on particular screen (TV screen in my case) regardless of how many screens are connected and enabled and regardless of which one is set as main / primary screen?

My second issue is quality of graphics in 4K / UHD - I do not see any difference between Full HD and UHD settings in Zwift (when displaying on my Samsung TV set) and I wonder whether Zwift is actually running in 4K / UHD or perhaps due to some issues with resolutions specific to my hardware setup it is actually not (despite what setting it shows in setup menu)?? Suspicious particulars are: a) graphics in UHD / 4K are in heavy need for antialiasing exactly the same as in Full HD mode, b) competitive apps like Road Grand Tours or even VirtuGo look so much better in 4K / UHD, I can easily see big difference. Is there a way to check if Zwift is actually running in 4K? If it is not – is there a way to force it to run in 4K (I was googling for answers but have not found any)??


Looking into your 4k question, but for your first question have you tried this:

Open the application, drag it to the screen you want it to launch on, minimize it to half size by clicking the minimize button next to close window, then close Zwift without maximizing it again. Then launch again and check to see if it launches on your TV screen.

Edit: For your 4K question: The UHD is truly the highest resolution. I have no info on forcing Zwift into a graphics overhaul but I say whatever you can find, try it out.

This might not be related to your problem but I am using an Nvidia GeForce GTX 1050ti video card and could not get 4K resolution over to my TCL 50" Android TV. It turns out in my case I was using a DisplayPort (video card) to HDMI (TV) cable that for some unknown reason was limiting my resolution to 1080p. After replacing my cable and using a HDMI (video card) to HDMI (TV) cable instead I was able to get full 4K. I didn’t notice any huge differences between 1080p and 4K but I did notice improved graphics and shadow effects from utilizing the Nvidia GTX 1050ti card. These additional improved graphics did not exist when I was using the on-board Intel graphics card. I also make sure to run in Full Screen mode instead of the default Windowed mode.