Avatar wont move

so I am trying to do a prelim ride on Zwift before making a decision. I previously rode in December (a bit) and had some previous questions. However, i log in and zwift tells me i still have 25 free kms.

So i decide last night (after knee injury has healed) to resume.

My speed sensor was paired, my cadence sensor was paired, and my Tickr HR strap was paired.

I selected a Balackburn classic trainer.

I clicked on the “lets go” button,…and nothing?

i pedal for five minutes, nothing?

i restart , sign out, delete and reinstall the app…still NOTHING?

I wasted an hour of time trying to ride with Zwift.

Finally, I gave up. Not impressed.

Why would it work for me before? and not last night? (my wi fi is strong, and i have wi fi booster, and small house, so its not on my set up).

Please advise I want to try again


When you are in the paring screen do you see the speed increase when you pedal.

1 Like

Could it be that your free trial has ended based on time away? I would think that when you logged back in you should have been notified but one never knows.
Like Gerrie says, sometimes your sensor might say paired but not transmitting correctly so verify that you have numbers updating in the speed box because that is what moves your avatar.
Also, one last question: How are you determining that your speed sensor is paired? Many stand alone sensors can support either cadence or speed and you need to configure it for speed or cadence. The cadence sensor does not move your avatar. .

i spin the pedals and the cadence was showing, and my HR was showing…no speed, no movement

If not speed is showing in the paring screen then there is something not right with the sensor or the magnet or the battery.

i have a garmin watch as well. speed records on it. same with cadence. so cannot be batteries. should i unpair from my watch? or shut the watch power off?
i did not last time, and it worked

Maybe I’m not reading your posts correctly but cadence does not move your avatar. You need a speed sensor on your rear hub.

i do have the speed sensor on the rear hub. i just went home at lunch, and tried my bike thru apple tv, and it works.

it was on the ipad last night, that it would not work.


Both of those devices connect via Bluetooth, which allows only a 1-to-1 connection between devices. Is it possible that your speed sensor was still connected to your Apple TV, thereby preventing it from connecting to your iPad? You might try ‘force quitting’ the app on the ATV after each use, and then see if you still have issues connecting to the iPad. (And you might want to force quit Zwift after using the iPad, also, to avoid some potential issues when then going back to the ATV.)