Avatar not moving despite all paired

Hi, I am new and have zwift setup on ipad. First ride was great. Now second ride, despite power meter and cadence meter connected and correctly displaying values in zwift itself, the avatar is not moving.

Though it does not seem an issue of connection I unpaired and repaired twice, changed the course but the issue is not solved.

I am deciding wether to buy subscription or not but it makes sense only if it works 99.9% of times… any help?

Thanks!

Continuing the discussion from Avatar not moving with everything paired:

My guess is you are on the Free Trial and you have exceeded the mileage allotment and that is why your avatar is not moving: https://support.zwift.com/zwift-free-trial-B1WDzRJBX

iOS/tvOS

For starters, you get 25km (about 15.5mi) to try out Zwift; this starts with your first pedal stroke. After that, select JOIN NOW to get an additional 7 days with unlimited distance. If you choose not to become a member at the end of the 7-day trial period, you can cancel before then without being charged.

2 Likes

Hi Paul_Allen, thanks, that could well be the case as my first ride was about 25km… I’ll look more into it, thanks again!

Hi,

I face the same problem recently. I didn’t change a bit on my setup, worked for years.
My avatar gets on the pedals when I pedal (Cadens is shown and Power output as well) but the clock doesn’t start and the avatar is not moving.

ZWIFT please help!

Check and see if your subscription is up to date.

That worked, thanks.

1 Like

All
I have the same issue.
New Tacx Bushido.
Using an iPad.
My sensors are connected
My Avatar won’t move and cadence and power read zero.
It all worked yesterday.

I have done the following:

  • reloaded the app
  • logged out and logged back in
  • disconnected and reconnected speed / power sensor
  • turned blue tooth on and off
  • been at this for an hour.

Any suggestions?

Getting very frustrated