Apple Watch not connecting? "No Signal"

Hi,

I have been successfully been riding with my setup below for the past couple weeks. I do the power and cadence through the Assioma’s, Trainer through Snap, and heart rate through the Apple Watch via the companion app.

Today, however, my watch wouldn’t connect through the companion app. It would see it - but would show state “No Signal” in Zwift, and unpaired on my watch. In the companion app on my phone, I could see my watch, but it had an exclamation point on the right side of it.

I am apple to see my heart rate directly on the Apple watch via other apps (heart rate,heartwatch). So the watch isn’t broken, it’s not connecting for some reason.

Any thoughts? Does anyone else have this setup and are either experiencing similar issues or not (so I know its 100% on me)?

My setup is:
Kickr Snap (refurb’d 2017)
Assioma Duo (newest firmware)
AppleTV 4k
AppleWatch Series 4
iPhone X

Hey Ben, were you able to try reinstalling the Zwift Companion app and see if there were any changes for the better? Besides that, have you tried pairing your Apple Watch first before pairing anything else?

1 Like

Hey Vinvent, I’ll try these two things tonight. My phone completely bricked over night, and was able to get a free replacement from Apple. So it might have been connected to this.

Thanks

Ben

Hey Ben,

I had the same problems and also made a post in regard to this issue. When I went for my ride today (October 30th),I noticed that Zwift on Apple TV 4K received an update. I don’t know if it’s a fluke, but I had no problems at all. Hopefully the “bug fixes” were related to our issue.

I have also not been able to connect with my apple watch. I have the latest version of apple watch if that helps?

1 Like

I have the same problem. For weeks it worked fine and suddenly stopped. I tried so many things. Also a complete reset of the watch. Until today it’s not running anymore.

Any solutions on that meanwhile?

1 Like

Hello everyone. Just checking to see if anyone has found a good method to keep an Apple Watch synced as a heart rate monitor. I am new to Zwift, and heart rate monitoring worked well at first but hasn’t worked the last time I rode. I am using Zwift on my laptop, running the Companion app on my iPhone 7 and I have an Apple Watch series 3.

Since Zwift, in their official help on the subject, says it’s tricky to get it working consistently, I’m thinking of just buying a separate bluetooth heart monitor. Hmm.

Thanks,
Steve

1 Like

Marks post/steps helped me:

  • Reboot your Apple Watch before each ride.
  • Start Companion App
  • Start Zwift
  • Unclick the HR square with the Apple Watch connection
  • Pick your map, etc and begin
  • Before pedaling, hit Menu and go to Pairing
  • Click on the HR square and chose your Apple Watch
  • Exit to your rider and click the BLE icon in Companion App and pick your Apple Watch
6 Likes

Thanks! I am not sure what happened that one time, but following Zwift’s step-by-step instructions to get everything synced has been working very well.

I’m keeping this thread bookmarked just in case it starts to flake out at some point.

-Steve

Actually, the only thing I do is to start the companion app every time before I start Zwift. Although I close Zwift completely (double-click the right mouse button to enter tab mode and swiping up/away the Zwift tab) before turning off AppleTV.

Ride on
Cy

1 Like

My Apple watch heart rate is actually the most reliable now! I have been having issues with my Kikr Snap disconnecting from my laptop, so I’m buying an ANT+ Kit, which I hear can fix all kinds of connection issues.

Thank you! After much anxiety and even buying a new goddamned Apple Watch, because I thought my perfectly good series 2 wasn’t sophisticated enough for connectivity, it finally works. What a complete pile of ■■■■ that Zwift can’t piece this together.

5 Likes

I am able to connect my apple watch following Zwift’s guidelines but I get “no signal”.

Also…to those who have been able to get their watch to actually connect…does it log in the activity center? I have my zwift set to sync to strava and it does not log any activity with my watch…so I also have to run the strava app to get it to log.

I thought company was pretty established? I got my trainer this week and have nothing but technical issues. .

2 Likes

yeah iwatch just says unpaired, does open when I try to connect in the app, the app thinks its connected.

I figured it out, I had not allowed apple health data the first time. Removed the app and added it again, and this time after allowing all categories it started working.

I continuously and constantly have connection issues between Apple Watch and ZC / Zwift (companion on iPhone, Zwift on iPad).

I use Wahoo HR monitor, but Zwift randomly decides it should attempt to connect to Apple watch, and from that point onwards I just can’t get the Wahoo HR monitor to connect. I have now deleted ZC from watch, switched off Blue Tooth hopefully this will work, because this makes me really grumpy.

Nothing worse than being just in time for an early morning scheduled event and then having to deal with connectivity issues …

2 Likes

The Apple Watch app was working beautifully until this last iOS / WatchOS update. Now, it connects just fine, but then unpairs itself the second I start riding. The only way to get it to work again is to reinstall the watch app. Of course, I have to do this every single time I ride on Zwift and it’s getting pretty annoying so I may have to go back to the chest strap for HR, even though I dislike chest straps because they irritate my skin a little bit. I don’t know what, but something changed with the latest operating system updates.

7 Likes

Yep, I’ve had much more trouble since iOS 14 and watchOS 7. I added a post to bugs and support earlier to see if anyone else noticed the same (and to see if anyone has a ritual that seems to get them to work!)

1 Like

I’m having the same issues, not sire if this was after the update though. I rode at least once after the uodate and ti was working although the HR signal was continuously dropping. Today there was not way to connect the 2 of them. Zwift on the iPad kept on saying there was no signal, same on ZC whereas the app on the watch was saying unpaired.
How annoying. When on the traine I prefer to wear just the watch instead of the chest strap.

1 Like

I’ve been having this problem since the last Apple and Zwift updates. Strangely, I’ve also noticed my speed data (from a RunPod) being erratic and inaccurate since the updates too. I thought I might just have double bad luck, but I’m starting to wonder if it’s all related somehow now.

Today it was showing my speed at around 10kph, but when I switched over to the paired devices view it showed 11kph (via RunPod) which was perfectly in sync with my treadmill speed. The interesting thing is that looking at the Bluetooth devices managed through ZCA, it appears that “Apple Watch Run Speed” is connected? I wonder if there’s some kind of conflict in data sources which results in the “No Signal” issue?

I used to be a happy Zwifter with little issues before the most recent updates. I hope this problem gets recognised and fixed. I’m pretty sure it’s not me and my devices… the timing of the problems is a little suspicious! :slight_smile:

1 Like