(Fixed) Companion App/Apple Watch issues?

Anyone else having issues connecting their Apple Watch to Zwift since the most recent Companion App update two days ago? Zwift couldn’t find my watch at all. I did the usual troubleshooting (rebooted, etc).



Had one ride with my watch that I was gifted for my anniversary. Update came the next day and cannot get it to connect since then. Frustrating.

I’m having the same issue. Apple Watch has been working perfectly for months, but after the most recent Companion app update, the iPhone app starts the Watch app and it seems that the Watch app crashes immediately. I have deleted and reinstalled the Phone and Watch apps — but no luck.

(Since this most recent update I have been using my Garmin chest strap heart rate monitor. The Companion app syncs with Apple Activities — but only the Exercise Circle updates — not the Movement Circle (?). And obviously the heart rate data is missing from workouts. So I have been using RunGap to import the Zwift workout into Apple Activities. This updates the Movement Circle and includes the heart rate data. Definitely not ideal.)

Thanks guys. I’ll submit a support ticket. The QA at Zwift is brutally bad, it seems.

I’ve had the exact same issue for the past 24hrs, Companion app on the phone opens fine, but the watch app doesn’t connect and pushes to the background when trying to pair. Have emailed support but no help yet, so please let us know if you get any joy?

Support has it. They said they are notifying “Tier 3” support, whatever that is. I’ll post once I hear back. QA should really have been on this before it was released. Seems like an easy thing to check.

Nice one Mark. I agree. I have the same issue.

1 Like

Having same issue here. Started on Saturday morning. The companion app on the watch would start, it would then disappear. Did a lot of troubleshooting but just doesn’t want to pair.

What version of WatchOS is everyone running? I’m running 6.0. I do have an update pending for 6.0.1 so I might install this and see if it makes any difference.


I am running the newest version. It’s a Zwift issue and not related to the WatchOS version. Go ahead and send support a ticket. I figure the more they receive, the more they realize how many use Apple Watches.

I too am having this issue

I have the same problem and nothing work. The support is bad.

Did you check all your permissions on the watch, do Zwift have permission to access the blue tooth and other sensors?

Yes. It’s a Zwift programming bug. They acknowledged the issue.

To be perfectly clear on the bug, no HR readings show up in Zwift, and the Companion App on the iPhone either crashes or shows as disconnected. However, the ride and the HR reading are registered and stored in the Activity App. Really, it comes down to not seeing an HR number live or after the ride in the App.

1 Like

You need to update your iPhone to 13.1.3 as Apple broke pairing on the watch.

It has changed, but it still doesn’t work

Strange. Updating to 13.1.3 on my iPhone solved the issues for me.

I don’t know if it makes a difference, but I disconnected everything, restarted all the devices and now when I start it all up it works fine.

I have my KICKR connected to my iPad and my watch connected to my iPhone by the companion app.

After i restarted all the devices it works for me too, so now i’m happy :+1:t2::smiley:.
Thanks Adam

1 Like

Still not fixed? Reinstalled Zwift and Companion app on iPhone 8 and Apple Watch but still not possible to get heart rate monitoring up and running. App keeps crashing or says it is paired, but no heart rate visible.

I got the heart rate monitor working. I updated my iPhone and the companion app. I then turned the phone on and off. And same with my watch.

I’ve got an iPhone 11 Pro Max and Apple Watch 3.