(Fixed) Zwift Companion Apple watch is crashing

Good day,

today wanted to ride and noticed the app on the Apple watch is crashing. My rig:

iPhone 11Pro, Apple Watch 5, Mac Pro newest software.

My last ride was one week ago same setup (difference is last week was on 10.14 now 10.15) and everything was fine. Tried to uninstall everything and install again, same issue.

It is possible to start zwift companion on iphone and on apple watch, but in the moment you start zwift software on mac and the iphone will connect the app on the watch is crashing. Restart the app means it pop ups for half a second and goes back to homescreen. Actually using a normal HR not the watch.

Anyone same issue? Looks like it is 10.15 the problem or zwift needs an update. There was today an update, but did not helped.

You are not alone, Jakob. I’m on an iPadPro, iPhone 11Pro, Apple Watch 4 (all up to date) and experiencing the same crashing issue on the Watch Companion app. I also uninstalled and reinstalled everything to no success. If anything, I hope this reply spurs action.

1 Like

Friend of mine same issue on AW4 iMac and iPhone 7.

Have not the same issue, but cannot start zwift on the apple watch. Watch app says always, i would need to install zwift on the paired iphone, but there zwift is installed. when i‘m trying to pair a heartbeat monitor in zwift, the apple watch doesn‘t appear in the list but the zwift watch app is starting but telling the same message mentioned above.

i believe the problem is the new app store in watchos and the zwift apps needs updates.

btw: i have exactly the same issue and message with Strava.

Having the Exact same issue since Oct 13th. It was working on 10th. Didn’t ride on 11 and 12 so I cannot tell which day it stared. Hope it get fixed ASAP.

Had the same problem with my last ride. Apple TV, iPhone iOS 13.1, Apple Watch watchOS 6. Ended up completing a group ride without HRM and Cadence.

same here, Zwift companion app on Apple Watch 3 (watchOS 6 latest update) is starting, gets paired, shows NO hr and crashes one second after… rebooting iPhone (11 pro iOS13 latest update) and watch doesn’t work.


Exact same situation here. Even just updated to iOS 13.1.3 on my iPad 2 air, and my iPhone XR.

No Heart rate via the companion app, as this is the only way to pair the iWatch4 (iOS 6.0.1)

This is the only HRM I have, so I hope it gets worked out soon. Cheers for bringing it up!

From Zwift, after sending an email with a link to this discussion, 5 minutes later (very impressive support team):

Hi Maj,

Thanks for reaching out and reporting this issue; I’m sorry to hear about the trouble!

I’ve checked with our team and they’re working on a fix. While there isn’t a work-around for this issue as of yet, the fix will come from our end and all you should have to do is keep your Zwift app up to date.

We appreciate your patience and understanding as we continue improving Zwift. Please let us know if there’s anything else that you need assistance with; we’d all be more than happy to help!


John S.
Member Experience Agent


The good news (sort of) is that even though the Apple Watch app crashes and there is no heart rate showing in Zwift, the Activity App records the activity under Zwift and shows the heart rate, avg heart rate, etc.

1 Like

Same issue on Apple Watch series.3 and iPhone XR. Companion crashing on Apple Watch.

I see this too, though when you export the zwift ride into training peaks the heart rate doesn’t register. It’s only in the workout app on the iPhone unfortunately

same here, i used it without any problems on the 10th and yesterday realized the heart rate was not showing, (Iphone Xs with companion app and Watch S4) hope they can release the fix as soon as possible!!

I just started up Zwift after taking the summer off and my heart rate isn’t working with the Apple Watch now. It worked perfectly on the spring so I’m not sure where the problem is. I have a new phone and watch, and the software is all updated from when in worked in the spring also. Any ideas? I’ve tried every suggestion I’ve found in the forums short of putting my socks on inside out and my helmet backwards but haven’t had any luck yet. Everything says it pairs correctly but there is an explanation next to the watch in the Zwift Companion app and the watch app either doesn’t display a heart rate, or it simply crashes. Has anyone else experienced this?

1 Like

same here. had this too for last couple of days. i’m just glad to hear its not just me or my tech. clearly a bug of some sorts. I put a ticket in about it but as yet heard nothing. i will update if i hear anything.

10.15 is for developers longer than one month for download. Likelihood is high if you have mac system that you also have an iphone and an apple watch. So no one of the proggers have tested this simple thing! Now you have the answer why zwift is so buggy, there are only proggers not anyone for testing. We are testers not consumers :expressionless: Same on tacx…

Same issue here.

I have same problem. IpadPro, Apple Tv 4K with the companion app, and zwift direclty on the phone no companion. each time I connect to a ride, the Apple watch 3 says its paired but as soon as it switches to the ride screen, the app crashes. I have uninstalled and reinstalled everything and rebooted all devices. I have also checked for the current patch level everywhere

Same issues here. Worked on the 10th. No longer worked on the 11th. Use the Watch as an HRM. ZC crashes on my Watch when I use Zwift app on either Mac or 4K Apple TV.

As a workaround, the HRM on the Watch does work if I use the Zwift app only via my iPhone and Watch and don’t use ZC. I then mirror the Zwift app from my iPhone to my Apple TV so that I can view on a big screen. Else, you are stuck just using the Zwift app on your iPhone.

Same here. Watch companion app will crash every-time I try and use it. I tried Zwift on a PC, iPad, and mac but no luck. Seems that the companion app will just work right now when trying to use Apple watch as a HR sensor.

Only thing that is working is using the phone itself and the Zwift app on apple watch works as expected so this is restricted to the companion app.

Hoping they have a fix for the companion app soon!!