Apple Watch

Hello, I’m new here and although I’ve searched I’m not finding answers to my question.

I’m running an AW 2 with an iphone 6 and an Apple TV 4k. For the first 4 sessions the apple watch synced and delivered the HR perfectly on screen. Now, despite rebooting all the hardware and following the standard protocol the menu shows the apple watch as " connected" but also says " No signal ". Does anyone have any suggestions ?
Thank you in advance.

I’ve been struggling with “No Signal” on Apple TV, using the Android companion app, for several weeks. I finally had a breakthrough which has yielded consistent pairings to the companion app. It may or may not apply to the Apple Watch, but you can read about my process for pairing sensors here:

Mark, reboot your Apple Watch before each ride.

Start Companion App
Start Zwift
Unclick the HR square with the Apple Watch connection
Pick your map, etc and begin
Before pedaling, hit Menu and go to Pairing
Click on the HR square and chose your Apple Watch
Exit to your rider and click the BLE icon in Companion App and pick your Apple Watch

This has worked for me consistently, but I think the most important step is to reboot the Watch by holding both buttons until the Apple logo appears. Let me know if this works for you.

1 Like

Thank you Mark, that helped.

I have a new issue now, my watch says paired but its not transmitting movement or Heart rate. my little runner just stands their doing nothing and my heart rate on the watch is just the dashed lines.

1 Like

Did you get this resolved?

I had the same issue but hadn’t allowed Zwift access to my health data in privacy.

Yep, still the same problem and in privacy I am sharing to both Zwift and the companion app. It worked fine previously!!