Weird bug when pairing BLE devices (Apple Watch) with Apple TV for running

companion
pairing

(Scott Dickey ) #1

I ran into a really weird glitch when trying to pair my new Apple Watch 4 with my Apple TV 4.

I have been running successfully with a cheap footpod paired to my Apple TV 4 for several weeks now. I just got an Apple Watch 4, and tried to pair it last night.

The watch paired with the TV just fine (as a heart-rate monitor) in ride mode, but when I scrolled to the run pairing screen, the icons (run speed sensor, hear rate and cadence icons i mean) started dancing around the screen as if I was scrolling through very fast. Note i was not touching the remote at all. I made a video of this here:


I tried several things, including force quitting the zwift app on Apple TV, unplugging the TV for several minutes, completely resetting the TV and re-downloading the Zwift app, and trying different methods of controling the tv with the Apple remote app (e.g. with the watch, with my phone, etc.). I could not get the icons to stop dancing around in the run-pairing screen. Again, the ride pairing screen is completely normal and the watch pairs just fine (as a heart rate monitor) so I’m confident it’s not an issue with the remote / TV / BLE connection, etc.

Any ideas?

Thanks!


(Aaron Zwanzig) #2

This happened to me the other day when I accidentally swiped to “run” on Apple TV 4k. The run pairing tiles flew across the screen over and over exactly like in your video. It took many many attempts to swipe back to “ride” to get it to stop, but eventually it did go. This isn’t helpful to you in any way, but does confirm that you’re not the only one it happened to.


(Brady Masik (Sr)) #3

I had this same problem yesterday (first time I have ever tried Zwift Running). I have an identical 11 second video. Tried on the iPhone app as well, and it behaved the same.

Have you solved the issue yet?


(Scott Dickey ) #4

Sort of… But not by doing anything specific. It seems to be less of a problem after an update.

One thing that seems to make a difference is making sure that no sensors are paired in the ‘ride’ screen (e.g. power meter, cadence, controllable trainer, etc.) before switching to the ‘run’ screen.

Good luck!