Apple TV Overscan adjustment

Would be great if we had an option to adjust the overscan or image size on the Apple TV app.

And before anyone suggests its nothing to do with adjusting the overscan of the TV, neither is it an Apple TV issue. Its the Zwift app that needs a little alteration by the developers…

It’s not the Zwift app’s problem.

You’ll notice that this overscan affects all of the functions of the AppleTV, not just Zwift.

The problem is the TV. Overscan is entirely a function of the TV. The HDMI negotiation agrees the resolution that the TV and ATV device use, based on what the TV tells ATV it can support - usually 3840x1920, 1920x1080 or 1,280x720.
The TV then decides how much of this is displayed. Almost all modern TVs default to showing the full resolution. A tiny minority don’t, and force the user to set the HDMI input to turn disable this mode (called Overscan). Manufacturers often hide this deep in their set up menus, and call it different things. Different TVs also overscan by different amounts, which adds to the confusion!

If you have a problem with overscan on your TV that you can’t resolve in the TV menus, call your TV manufacturer, not Zwift.

If you think that the TV is working correctly, and that the AppleTV is at fault, call Apple.

But the problem here is not with Zwift, and it is totally wrong propose to introduce an option to scale the output image size of the Zwift app on AppleTV. No other apps I’ve experienced on ATV need to do this.

1 Like

You wrote a much better explanation than i was trying to!!

Indeed this is true except that not all TV’s have overscan adjustment hence it would be nice to be able to adjust it within the app. I use an old TV in my garage… no doubt quite a few others also have a similar setup.

1 Like

Perhaps, but surely it would be better to get Apple to “fix” the ATV for all apps, rather than for a single app to “fix” it?

I too have the overscan problem on an older tv running at 1080p with no way to correct the overscan on the tv side. I found a workaround, but I think it might highlight a bug in either the tvOS or Zwift.

Here is what I did to get a better fitting screen.

  1. (optional - confirm overscan) Go to Settings->VideoAndAudio->Calibrate->ZoomAndOverscan you should see the Minimum rectangle but not all of the Full Screen rectangle
  2. (optional - if you messed with any of the setting already) Go to Settings->VideoAndAudo>ResetVideoSettings and reset the settings, then reboot.
  3. Start Zwift, you should notice the overscan issue like you normally do
  4. Hit home and go to Settings->Format->OtherFormats In addition to 1080p, your tv will hopefully support some other reasonably high resolution that you can configure to. Mine had 1680x1050, not quite as good as 1080p but setting that I was able to go back to Settings->VideoAndAudio->Calibrate->ZoomAndOverscan and confirm that I could see the entire FullScreen rectangle.
  5. Go back to Zwift and your display should fit the screen correctly.

Here is where the bug part comes in.
While you may think you are all done, if you reboot the appleTV and start Zwift the overscan might be back, and this time even worse.
If you get into this state just start at step 2.
If you have not started Zwift get you probably not have to do the reboot, just reset the video, start Zwift and then change to your best non-1080p resolution and go back to Zwift.

So bottom line it seems if you start Zwift at 1080p and then adjust the resolution you can correct the overscan.
The bug (and again I don’t know if it’s Zwift or tvOS), if you start Zwift at some other resolution it does not seem to display the same as if you start at 1080p then change resolution and go back into the game

I have the same problem with Apple TV 4k and Sony TV of 40"
Only have this problem with ZWIFT, the other apps fit perfectly.
I have checked all the TV and Apple TV settings and can’t fix it, can you help me?

Unless you can adjust the picture size on the TV unfortunately there isn’t much you can do. I got fed up with it and bought a cheap 40" TV now it works fine.

I really appreciate your answer, I will check the TV settings again but I am very afraid that there is no solution.
I am reading in forums and manuals about the problem, lately I am more busy with this problem than pedaling in zwift. :woozy_face:

1 Like