Apple TV 4K not uploading rides to Strava etc

Hi have recently gone to Apple TV 4K and all worked fone first couple of days saved and uploaded rides and runs but now it says it is saving but clearly doesn’t and doesn’t cross populate to strava, anyone else had these issues? I have tried disconnecting link to and from strava and reinstate it but still the same

Not sure if rides are actually saving though … all data for the activity shows before save but nothing else

Cheers

Rob

Manualy, nake sure your Apple TV OS is updated and do the same for the Zwift app. Do not count on the auto-update function. Why? Because it is not immediate and thus could take a day or two.

Using the Zwift Companion app, do you see your “missing ride”? If so, then Zwift saved the ride, but for whatever reason it did not sync with Strava. If not, then you have a different problem.

Here is what I do… After finishing your ride and saving, do not exit Zwift. Check Strava to make sure the upload took place. Then, exit Zwift.

Also, when exiting Zwift and/or the Companion app, always force quit/close them. With the Apple TV, this is done by double-clicking the button w/the TV icon, followed by a swipe up.