Apple TV 4K crops screen edges


(Jon Schul) #1

I am new to Zwift. I have a new KICKR Core that I have linked to a new Apple TV 4K. If I screen mirror from my iPhone 6s Plus to the new Apple TV 4K the screen edges are fine. When I run the Zwift App on my new Apple TV 4K the screen edges are cropped. I would much rather just run the Apple TV 4K than screen mirror via my IPhone. The problem seems to be with the Zwift App on Apple TV 4K. If anyone has a fix for this problem please help.


(Vincent) #2

Hey Jon, try changing the resolution on your Apple TV 4K. 1.
Head to Settings -> Audio and Video -> TV Resolution.
Choose a screen resolution (try a few out until you find one that’s best).

Let me know if that helps at all!


(Rob Case) #3

I had the same issue and I had to set the zoom on my TV for the HDMI input to a different format. It wasnt just for zwift, it was an apple TV issue.


(G) #4

I have the same problem … run Zwift on AppleTv -> connected to older plasma TV. The screen is cropped as I haven’t found any solution on how to fix it.

  • I tried all possible resolutions in Apple TV (az Vincent advised) - no fix
  • I can’t change screen size (zoom) on my TV, as it simply doesn’t provide such function … I can only shift horizontal/vertical.

Thus I have to run Zwift cropped - missing edges on both sides (left/right) … an annoying a little bit, but still playable.

This is not Zwift error, but if it provides some “additional screen size setting”, then it will be great


(Jon) #5

Hi,
This is a strange one… I am running Apple TV 4K, and everything runs perfectly (connected via HDMI to a relatively new Samsung TV) … I have however had it once where the screen is cropped (i.e. goes off the edges), but I was able to go into the TV menu settings and ‘auto’ adjust the resolution and it was fine again.

Can only guess this may be an issue on older TV’s? You could always try disconnecting the HDMI lead and either connecting to another port or reconnecting to see if this ‘forces’ the TV to detect the correct resolution…?

Hope that helps, I imagine it must be frustrating having the display off the edges.


(G) #6

Jon - yes, the problem is (probably) outdated TV. It’s quite old (guess 15 years - and believe me as 55" Pioneer plasma it was pretty expensive in those days). As it still works fine, I try to keep and use it as long as possible.

There is just one HDMI input (and several SCARTS which I don’t use anymore), so I have to use HDMI splitter (hope it’s the correct term) to connect all devices I need nowadays - IPTV, PS4, AppleTV, older WD streamer … I did my best to find some function like “set screen size … resize… etc” in TV’s menu, but nope. Just shift left/right and up/down, which doesn’t help me, of course …

And yes, it’s irritating I can’t see the whole picture, but never mind - as I’m able to see the most important information, I can live with it/got used to it … check my screenshot (sorry for poor quality) I just miss the real edges - part of rider’s names, flags, etc … nothing crucial …


(Jon) #7

Hi @Godmother_Fox,

Yeah, its only marginally out isn’t it, but still not right… I don’t blame you for keeping the TV going - a 55" is a good Zwift setup! :+1:

As a process of elimination, I’d try connecting the Apple TV HDMI directly into the TV (bypassing the splitter), just to see if it then picks up the correct resolution… if it does you then know it is something to do with the splitter… If that is the case then you could either 1) remove the splitter each time you Zwift or 2) look at getting a different/newer splitter.

Just ideas and some things to try, let me know how you get on.


(( C)raig) #8

This worked for me:

Adjust from the menu on your TV or projector

Some TVs and projectors let you adjust overscan or underscan from a settings menu or button on your remote. Look for a Zoom button or check your TV or projector for a menu called Aspect Ratio, presentation mode, computer mode, or a similar setting.


(Jon Schul) #9

I have also tried all possible Apple TV 4K screen resolution settings and none helped. I tried with a second TV at my home and the result was the same. It doesn’t seem to be a TV problem. Should I try deleting the APP and downloading again and re-installing? It seems to be the APP not my equipment as far as I ncan tell.


(Jon) #10

Hi,
Before uninstalling the app, in order to confirm if it is just app related, do other apps (other than Zwift) show correctly?

If other apps are working fine and fit within the screen and Zwift doesn’t then, I would say yes, try uninstalling/reinstalling … obviously if other apps are also not displaying correctly then I don’t think trying to reinstall would be a fix. :thinking:


(Chris Johnson-Brown ) #11

Hello,
First, I apologize if this is the wrong place to ask these two questions.
The following explantion, and scenario, is the reason for asking these two questions.
My laptop can run zwift, although, the graphics are horrible, and, the rides are choppy. My television, is, a 4K television, that supports, both UHDR, and Dolby Vision. I am, thinking about purchasing, the Apple 4K TV for zwift only, because of the former. Also, My “true” internet speed is 25 Mbps (roughly 200 Mbps) not MBps.
However, before I do, and continue, using zwift, I would like to know, if zwift can run at 4k, and how zwift “streams”. Here are my questions. Does Zwift run procedurely or pre-process at 4k resolution? To put it another way, what resolution does Zwift broadcast?


(Pieter Brankaer) #12

Thought I’d add to this topic since my problem is very similar. I’m trying to run Zwift on Apple TV 4k on an old 20" PC monitor with a 1680*1050 resolution.
Resolution is correctly setup in the Apple TV settings. Everything displays correctly in all apps except in Zwift, where information is cut off from the top of the screen. This surprises me; because of the 16:10 aspect ratio of the screen I’d expected some vertical stretching or something similar but not this.
Any idea on how this could possibly be solved?


(Silly Bugger) #13

I’m having the same problem. The image of the Zwift screen is cropped slightly, such that it:

  • cuts off the rank of individual record holders on the left
  • the value of the current incline I’m riding on the right,
  • the flags of the nearby Zwifters on the right,
  • and something from the bottom (below the heart rate track) during workouts.

I get almost the same result on two different Apple TVs connected to two different TVs, though the cropping is more pronounced on the 4th Generation Apple TV connected to an older 720p Samsung Plasma HDTV than a brand new 4K Apple TV. Unfortunately, there’s no resolution that I can choose on either Apple TV that enables the cropped portion to become visible, and there’s no way I’ve found to adjust the overscan/underscan (i.e. zoom) of either TV to rectify the issue. This is the only app installed on either where image cropping affects my ability to see or use any other Apple TV apps.

Like others I’d love some way of customizing the position of the windows that display the records, the map and nearby Zwifters, but if that’s not possible I’d settle for seeing the %incline via the companion app.