Zwift Application Oversized on AppleTV

I have a 5-6 year old Sharp Aquos TV with a 4K AppleTV and Wahoo Core smart trainer paired via the Zwift companion app. When opening the Zwift application on the AppleTV, it works perfectly for 1 to 2 sessions, but then something happens to the aspect ratio of the application (only Zwift) causing it to crop the edges without me changing anything on the TV to AppleTV. The only solution I’ve found is to reset the AppleTV, delete the Zwift app, and reinstall it after each use. Its a bit of a cumbersome solution, but the only thing that I’ve found to work. I’ve tried changing the aspect ratio, checking to make sure the image is not actually oversized, shutting out of the application after each use, and even tried another 4K AppleTV, but none have worked. I’m pretty convinced its a bug with the program itself as all of the other applications on the TV run perfectly fine (I’ve also tried a different AppleTV and had the same issue). Short of buying another TV, not sure what else to do!

Take a look at this thread and see if it helps:

I read this thread prior to posting, and went through all the different aspect ratios on the AppleTV itself with no luck. Actually, all of the other applications adjust their aspect ratios except for Zwift - it’s as if something get corrupted during the application startup process that can only be reset by resetting the AppleTV and reinstalling the application.

I’ll post a photo tomorrow of what exactly is happening

Hi, I had a very similar problem when trying to use an older 40" Sony LCD screen.

Unfortunately the only solution I found was to buy another tv…

Outside of the aspect ratios, did you try the ‘overscan’ option? That is what fixed it for me.