Anyone else having issues with bluetooth through companion app as of late?

They’re messing about with Bluetooth at present: Bluetooth improvements for controllable trainers & treadmills [January 2022] - #121 by shooj

1 Like

I can confirm that the issue has been fixed by downgrading to companion app version 3.31.1.

https://companion-zwift-inc.en.aptoide.com/versions

@Robert_Dudziak :point_up:

2 Likes

@Kim_Eik

I heard back from the team and was able to get confirmation that there appears to be an issue with Zwift Companion (ZC) version: 3.33.0 on Androids (including Android 10, 11, and 12) where the ZC BLE bridge to pair devices doesn’t work properly. Our team is investigating this and thanks again for bringing this to our attention!

2 Likes

Super! Also seems not all devices are afflicted by this error as my wife’s phone with Android 10 seems to work fine with the latest companion app. :person_shrugging::man_shrugging:

1 Like

Hi @Kim_Eik

What you say makes sense and hopefully I’m not overstepping here, but from what I understand it’s been a somewhat difficult issue to reproduce on our side. I believe multiple different Android devices were tested using the current ZC app version, but I don’t think the issue has been reproduced as yet. My info could be out of date, however, and I know our team is still actively looking into this!

Thanks for the feedback. Hope it gets fixed soon.

This is the device that the latest companion fails for me. It is 100% reproducible on my end. Everytime companion gets updated to latest version. Then no Bluetooth connection. And when i downgrade, then everything is fine again.

Hi @Kim_Eik

As I understand it, the ZC app version 3.33.1 for Android was released before the weekend (e.g. March 9th I believe) and was intended to resolve this issue. Please update your ZC app if you haven’t already done so. There should be more info here. Thanks!

Have done several rides since the 3.33.1 Companion update and it definitely does not resolve the problem (especially when used in tandem with the latest 1.23.0 Zwift update).

Hi @William_Harrison1

Since the update was said to have resolved the issue, we’ll need to troubleshoot any lingering ZC connection issues on a case-by-case basis.

Were you one of the folks who previously tried downgrading to ZC app version 3.31.1 and discovered that doing so resolved the issue? Just to be clear, I’m definitely not suggesting that you do so, but I just wanted to know if that was something you’d previously tried and if it resolved the issue or not?

To my knowledge, the known issue was that the ZC BLE bridge is not functioning at all, but looking at your account I can see that you’ve been able to pair your devices to Zwift using the ZC BLE bridge.

In what way is it not working and can you provide more details? Are your devices simply disconnecting from Zwift entirely and you’re having to pair them again or are you getting drops in power, resistance, etc…? Have you tried all the standard troubleshooting for this kind of issue as explained in this article?

@Steven_D I can confirm that companion app version 3.33.1 does get bluetooth connection and transmits that successfully to latest zwift version 1.23.0.

Will try a ride with this setup this week, and i’ll come back to you if anything else fails.

1 Like

Hi Steven,

Thanks for your response. No, I’ve not downgraded from the most recent (3.31.1) version of ZC in an attempt to resolve this issue. The problem is that the connection is not stable and can fail at any time without warning (once connected, the resistance & power functions normally). In order to achieve an initial stable Bluetooth connectivity using the ZC bridge, I have to spend an inordinate amount of time re-setting, re-lauching clearing caches etc.

Just to give you some idea of what this entailed yesterday for a simple free ride on Watopia, this is what I had to endure (I went through similar travails the day before with a Pace Partner ride, which I’ve already reported in a different thread).

Attempt #1

  • Unable to find Assiomas as power source on “Paired Devices” screen
  • Force-close Zwift app on ATV and re-launch

Attempt #2

  • All devices now paired successfully: Assiomas = power & cadence, Neo 2T = Controllable, Wahoo Tickr Fit = HRM
  • Selected red “Let’s Go button” to enter Watopia then selected ATV “menu” button to enter Zwift “Paused” screen to change Trainer Difficulty in “Settings”
  • Selected “Back” to return to Watopia to start riding BUT all connectivity lost (“Connection Failure” blue box in top RHS of Zwift HUD).
  • Returned to “Menu” and selected “Paired Devices” screen again. Here, the devices would intermittently “flash” between being connected (with a green tick) and then showing “no signal”. Even when everything was supposedly re-connected on the “Paired Devices” screen, the Watopia ride screen would still show the connection failure box and the avatar would not move.
  • Tried different variations of turning off Bluetooth on phone and force-closing Companion app and re-launching but nothing helped to re-establish the Bluetooth connections in the “Connection Failure” device box.
  • Back to “Menu” page and selected “End Ride” (not saved)

Attempt #3

  • Cleared Zwift Companion app cache on phone, re-started phone, force-closed Zwift on ATV then re-launched
  • All devices quickly found and easily connected on “Paired Devices” screen. Connected signals now seem stable.
  • Selected “Let’s Go”, Watopia & Tempus Fugit chosen and “Ride” selected.
  • Started free ride without any problems. Power, Cadence & HRM signals stable.
  • After ~30 mins, stopped riding and allowed the pedals to enter “sleep” mode (after 5 mins with no pedalling).
  • Once asleep, the Bluetooth connections (power & cadence) from the pedals were lost as expected.
  • Once pedalling re-started, the Bluetooth connections were quickly re-established and the ride continued successfully. However the Companion app Bluetooth icon still showed a red triangle with ! (indicating Assiomas not connected) despite the Paired Devices screen showing everything connected and the avatar moving as expected. This must be a ZC glitch!
  • Ride saved as usual & Zwift exited and force-closed as usual.

Summary

The Zwift & Zwift Companion-related failures do not appear to be related to weak wi-fi or wi-fi interference or Bluetooth interference from lights, fans, dehumidifier etc. They appear to be related to the recent updates of both the Zwift gaming app (to 1.23.0) and the Zwift Companion app (to 3.33.1).

Hi Steven,
Just a quick follow-up to my post above where I’ve noticed some anomolous data from my devices using the Strava Analysis feature for this ride. Just doesn’t make sense.

Towards the end of the ride, I stopped pedalling to allow my avatar to come to a complete stop. Obviously at this point my speed, power and cadence values should eventually fall to zero and my HR should be gradually dropping. I made sure not to move the pedals at all so that they would enter “sleep” mode after 5 mins (which they did). However, during this stationary 5 mins there are obviously “big” fluctuations in speed, cadence and power on my data graph, which shouldn’t exist. In fact, once the pedals entered sleep mode and the Zwift “Paired Devices” screen showed that the Bluetooth signal had been lost (as planned/expected), this isn’t reflected in my raw data i.e. I can’t see any point at which the power/speed cadence drop to zero in tandem when the signal was supposedly lost.

I’ve absolutely no idea what any of this means and whether it’s relevant at all to some of the power/resistance fluctuations people are reporting during rides. Maybe this is just specific to my power source on this occasion (Assioma Duo pedals; latest firmware, charged to 100% before this ride).

Another short follow-up.

Thought I’d do another quick test of the ZC Bluetooth bridge since I’m racing tonight and don’t want to be messing around with device pairing problems.

Same as my previous report (couple of posts above this one) and pretty much the same pattern of failure & “success” with the ZC bridge i.e. this isn’t some random Bluetooth interference which is causing these drops it is probably something associated with either the latest ZC update and/or the latest gaming update.

Again, it took me three attempts before I could establish what looks like a stable connectivity with all devices paired successfully. I say “look like” because I only rode for 4 mins and this connectivity failure when it happens is random and has happened to me in as little as 4 seconds into a ride or 1 hour 40 mins into a ride.

First attempt; same as before, couldn’t find any devices to pair as the power source.

Second attempt; everything pairs successfully at the “Paired Devices” screen but as soon as I select “Ride” and enter Watopia the blue data box at top LHS of screen suddenly responds with “Connection Failure”. I start to ride and this error message sometimes disappears but then reappears and all the while my avatar is moving as normal and I’m getting a read-out for W, RPM, bpm. I tap on the Bluetooth logo on the ZC and it is only showing my power/cadence device (Assiomas) as connected and my HRM as connected; no mention of the Tacx Controllable. When I switch back to the paired devices screen, however, all devices are showing as connected with a signal. Go figure! So, saved the ride and exited Zwift for a third attempt.

Third attempt (after force-closing all apps, clearing ZC cache & re-starting Android phone, ZC and Zwift); phone icon in top LHS of screen showing ! and no devices can be found again. Force-close ZC again, switch phone’s Bluetooth off/on and phone icon loses the ! and starts “pulsing” as the Bluetooth bridge is established. All devices now pair successfully and appear to be stable. Rode in Watopia for approx 4 mins without any issues, saved the ride & exited.

So, the ZC Bluetooth bridge is pretty much unusable for me if I’m at all concerned with completing any ride/race/workout. Before the latest ZC and Zwift updates, the ZC bridge worked pretty well for me (not flawlessly) and any in-ride drop-outs were usually momentary with the signal quickly re-established. Not any more…Very disappointed with this.

Hi @William_Harrison1

I read through your extensive descriptions and to be totally honest, it sounds like your issue is above and beyond what the experience has been for others impacted by the ZC BLE bridge known issue which was reportedly fixed last week.

At this point, I’d suggest that you write in to our support team to establish a dialogue with our Tier 2 tech support group. We’ll almost certainly need to examine your log files and continue the troubleshooting process in a more formal capacity with our tech team.

If you could let me know when you’ve written in for support, I’ll make sure everything you’ve shared here on the Forums is made visible to our techs as we work with you on this. You can reach us here.

As a side note, I’m curious to know if you’ve tried using a different device for the ZC app other than your Motorola moto Android. It would be good to know if your issue is isolated to the ZC BLE bridge when using that Android device specifically or if other mobile devices you’ve tried also exhibit the same issue. If you don’t have another mobile device you can use to try the ZC app, that’s fine; I just wanted to explore that possibility.

Thanks Steve. No, I don’t own, and haven’t used, any other Android device apart from my Moto G8 Power Lite phone.

TBH, and this may sound a bit “woke”, but I’m exhausted with all this messing about trying to make the ZC bridge work. I’m not a gambling man, but I would hazard a guess that there are more people than myself experiencing problems who probably don’t use this forum or can’t be bothered to report it etc., and are just as frustrated. The fact that the ZC bridge was working (not perfectly) for me before all the latest updates would suggest that it’s nothing to do with my devices and more to do with the apps.

I’m also not as tech savvy as many people on this forum so I don’t really have the inclination, time or enthusiasm to get involved in some kind of “deep dive” on this. I realise that this isn’t being very pro-active etc., but I’ve had enough. It either gets fixed eventually when enough people complain, or it’s an isolated problem which never gets resolved and, I guess, I can (or will have to) live with that.

Had a zwift race yesterday, and everything worked perfectly. So seem’s the patch fixed the bluetooth issues I experienced. Thank you for your assistance.

1 Like

Hi @William_Harrison1

I definitely get your frustrations, especially since the ZC BLE bridge was working fine for you before the recent updates.

The reason why I asked about your specific model Moto G8 Power Lite Android is because I saw another post on the Forums here where another Zwifter reported what appears to be a similar issue when using the same model Android device for ZC. It could be a coincidence or it could be a potential trend, but that’s what I’m trying to establish.

Since I’m not a Zwift developer and am merely a humble Zwift support agent, I don’t personally fix things having to do with Zwift that are broken from a programming standpoint, but try to do my best to identify trends and report them to the people at Zwift who do fix things. If I ask for more information from Zwifters or for Zwifters to try specific things, I generally make every effort to have a good reason for doing so. Either way, thanks for sharing the information and I’ll do my best to get some attention on this.

Hi @Kim_Eik

Great news! Thanks for letting me know that the patch seems to have resolved the issue for you!

Ride On.

Thanks Steven. Testing another Android device with the ZC app is definitely on my “to do” list. Don’t know where, or how, I’ll get my hands on one, but I’ll try.

1 Like